pnpm Has Lockfile Integrity Bypass that Allows Remote Dynamic Dependencies
CVE-2025-69263GHSA-7vhp-vf5g-r2fw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 10.26.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pnpm
- Affected
- < 10.26.0
- Fixed in
- 10.26.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7vhp-vf5g-r2fw lists affected ranges: npm pnpm >=0 <10.26.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7vhp-vf5g-r2fw lists affected ranges: npm pnpm >=0 <10.26.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-69263: 0.47% estimated exploitation activity in the next 30 days; percentile 41.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary HTTP tarball dependencies (and git-hosted tarballs) are stored in the lockfile without integrity hashes. This allows the remote server to serve different content on each install, even when a lockfile is committed. Details When a package depends on an HTTP tarball URL, pnpm's tarball resolver returns only the URL without computing an integrity hash: resolving/tarball-resolver/src/index.ts: The resulting lockfile entry has no integrity to verify: Since there is no integrity hash, pnpm cannot detect when the server returns different content. This affects: - HTTP/HTTPS tarball URLs ("pkg": "https://example.com/pkg.tgz") - Git shorthand dependencies ("pkg": "github:user/repo") - Git URLs ("pkg": "git+https://github.com/user/repo") npm registry packages are not affected as they include integrity hashes from the registry metadata. PoC See attached pnpm-bypass-integrity-poc.zip The POC includes: - A server that returns different tarball content on each request - A malicious-package…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7vhp-vf5g-r2fw
- Revision 1 · created ·
Published from osv record GHSA-7vhp-vf5g-r2fw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-69263 Advisory: pnpm Has Lockfile Integrity Bypass that Allows Remote Dynamic Dependencies IDs: CVE-2025-69263, GHSA-7vhp-vf5g-r2fw Record: https://patchnext.com/advisories/cve-2025-69263 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pnpm 10.26.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pnpm: affected < 10.26.0; fixed in 10.26.0 ## Suggested inspection (read-only) - `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pnpm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7vhp-vf5g-r2fw (OSV record GHSA-7vhp-vf5g-r2fw lists affected ranges: npm pnpm >=0 <10.26.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7vhp-vf5g-r2fw (GitHub-reviewed advisory GHSA-7vhp-vf5g-r2fw lists affected ranges: npm pnpm >=0 <10.26.0) Commands are suggestions: review each one before running it.
Loading voting…