Skip to content

← Actionable
High, CVSS 7.5amended

pnpm vulnerable to Command Injection via environment variable substitution

CVE-2025-69262GHSA-2phv-j68v-wwqx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 10.27.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pnpm

    Affected
    >= 6.25.0, < 10.27.0
    Fixed in
    10.27.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-69262: 1.04% estimated exploitation activity in the next 30 days; percentile 64.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A command injection vulnerability exists in pnpm when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve remote code execution (RCE) in build environments. Affected Components - Package: pnpm - Versions: All versions using @pnpm/config.env-replace and loadToken functionality - File: pnpm/network/auth-header/src/getAuthHeadersFromConfig.ts - loadToken() function - File: pnpm/config/config/src/readLocalConfig.ts - .npmrc environment variable substitution Technical Details Vulnerability Chain 1. Environment Variable Substitution - .npmrc supports ${VAR} syntax - Substitution occurs in readLocalConfig() 2. loadToken Execution - Uses spawnSync(helperPath, { shell: true }) - Only validates absolute path existence 3. Attack Flow Code Evidence pnpm/config/config/src/readLocalConfig.ts:17-18 pnpm/network/auth-header/src/getAuthHeadersFromConfig.ts:60-71…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2phv-j68v-wwqx

  2. Revision 1 · created ·

    Published from osv record GHSA-2phv-j68v-wwqx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-69262

Advisory: pnpm vulnerable to Command Injection via environment variable substitution
IDs: CVE-2025-69262, GHSA-2phv-j68v-wwqx
Record: https://patchnext.com/advisories/cve-2025-69262 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pnpm 10.27.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pnpm: affected >= 6.25.0, < 10.27.0; fixed in 10.27.0

## Suggested inspection (read-only)
- `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pnpm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2phv-j68v-wwqx (OSV record GHSA-2phv-j68v-wwqx lists affected ranges: npm pnpm >=6.25.0 <10.27.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2phv-j68v-wwqx (GitHub-reviewed advisory GHSA-2phv-j68v-wwqx lists affected ranges: npm pnpm >=6.25.0 <10.27.0)

Commands are suggestions: review each one before running it.

Loading voting…