Skip to content

← Actionable
High, CVSS 7.5amended

AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb

CVE-2025-69223GHSA-6mq8-rvhq-8wgg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiohttp 3.13.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aiohttp

    Affected
    <= 3.13.2
    Fixed in
    3.13.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-69223: 0.58% estimated exploitation activity in the next 30 days; percentile 47.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A zip bomb can be used to execute a DoS against the aiohttp server. Impact An attacker may be able to send a compressed request that when decompressed by aiohttp could exhaust the host's memory. ------ Patch: https://github.com/aio-libs/aiohttp/commit/2b920c39002cee0ec5b402581779bbaaf7c9138a

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6mq8-rvhq-8wgg

  2. Revision 1 · created ·

    Published from osv record GHSA-6mq8-rvhq-8wgg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-69223

Advisory: AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb
IDs: CVE-2025-69223, GHSA-6mq8-rvhq-8wgg
Record: https://patchnext.com/advisories/cve-2025-69223 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aiohttp 3.13.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aiohttp: affected <= 3.13.2; fixed in 3.13.3

## Suggested inspection (read-only)
- `python -m pip show aiohttp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aiohttp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6mq8-rvhq-8wgg (OSV record GHSA-6mq8-rvhq-8wgg lists affected ranges: PyPI aiohttp >=0 <3.13.3 (fixed))
- Verified: https://github.com/advisories/GHSA-6mq8-rvhq-8wgg (GitHub-reviewed advisory GHSA-6mq8-rvhq-8wgg lists affected ranges: PyPI aiohttp >=0 <=3.13.2)

Commands are suggestions: review each one before running it.

Loading voting…