Skip to content

← Actionable
Medium, CVSS 6.3amended

Signal K Server Vulnerable to Access Request Spoofing

CVE-2025-69203GHSA-vfrf-vcj7-wvr8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (signalk-server 2.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2025-69203: 0.30% estimated exploitation activity in the next 30 days; percentile 23.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The SignalK access request system has two related features that when combined by themselves and with the infromation disclosure vulnerability enable convincing social engineering attacks against administrators. When a device creates an access request, it specifies three fields: clientId, description, and permissions. The SignalK admin UI displays the description field prominently to the administrator when showing pending requests, but the actual permissions field (which determines the access level granted) is less visible or displayed separately. This allows an attacker to request admin permissions while providing a description that suggests readonly access. The access request handler trusts the X-Forwarded-For HTTP header without validation to determine the client's IP address. This header is intended to preserve the original client IP when requests pass through reverse proxies, but when trusted unconditionally, it allows attackers to spoof their IP address. The spoofed IP is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vfrf-vcj7-wvr8

  2. Revision 1 · created ·

    Published from osv record GHSA-vfrf-vcj7-wvr8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-69203

Advisory: Signal K Server Vulnerable to Access Request Spoofing
IDs: CVE-2025-69203, GHSA-vfrf-vcj7-wvr8
Record: https://patchnext.com/advisories/cve-2025-69203 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: signalk-server 2.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm signalk-server: affected < 2.19.0; fixed in 2.19.0

## Suggested inspection (read-only)
- `npm ls signalk-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on signalk-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vfrf-vcj7-wvr8 (OSV record GHSA-vfrf-vcj7-wvr8 lists affected ranges: npm signalk-server >=0 <2.19.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vfrf-vcj7-wvr8 (GitHub-reviewed advisory GHSA-vfrf-vcj7-wvr8 lists affected ranges: npm signalk-server >=0 <2.19.0)

Commands are suggestions: review each one before running it.

Loading voting…