Skip to content

← Actionable
Medium, CVSS 6.0amended

axios-cache-interceptor Vulnerable to Cache Poisoning via Ignored HTTP Vary Header

CVE-2025-69202GHSA-x4m5-4cw8-vc44

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (axios-cache-interceptor 1.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-69202: 0.32% estimated exploitation activity in the next 30 days; percentile 24.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When a server calls an upstream service using different auth tokens, axios-cache-interceptor returns incorrect cached responses, leading to authorization bypass. Details The cache key is generated only from the URL, ignoring request headers like Authorization. When the server responds with Vary: Authorization (indicating the response varies by auth token), the library ignores this, causing all requests to share the same cache regardless of authorization. Impact Affected: Server-side applications (APIs, proxies, backend services) that: - Use axios-cache-interceptor to cache requests to upstream services - Handle requests from multiple users with different auth tokens - Upstream services replies on Vary to differentiate caches Not affected: Browser/client-side applications (single user per browser session). Services using different auth tokens to call upstream services will return incorrect cached data, bypassing authorization checks and leaking user data across different…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x4m5-4cw8-vc44

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x4m5-4cw8-vc44

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-69202

Advisory: axios-cache-interceptor Vulnerable to Cache Poisoning via Ignored HTTP Vary Header
IDs: CVE-2025-69202, GHSA-x4m5-4cw8-vc44
Record: https://patchnext.com/advisories/cve-2025-69202 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: axios-cache-interceptor 1.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm axios-cache-interceptor: affected < 1.11.1; fixed in 1.11.1

## Suggested inspection (read-only)
- `npm ls axios-cache-interceptor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on axios-cache-interceptor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x4m5-4cw8-vc44 (OSV record GHSA-x4m5-4cw8-vc44 lists affected ranges: npm axios-cache-interceptor >=0 <1.11.1 (fixed))
- Verified: https://github.com/advisories/GHSA-x4m5-4cw8-vc44 (GitHub-reviewed advisory GHSA-x4m5-4cw8-vc44 lists affected ranges: npm axios-cache-interceptor >=0 <1.11.1)

Commands are suggestions: review each one before running it.

Loading voting…