Pterodactyl improperly locks resources allowing raced queries to create more resources than alloted
CVE-2025-69198GHSA-jw2v-cq5x-q68g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pterodactyl/panel 1.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pterodactyl/panel
- Affected
- < 1.12.0
- Fixed in
- 1.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jw2v-cq5x-q68g lists affected ranges: Packagist pterodactyl/panel >=0 <1.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L · score source
- EPSS
- CVE-2025-69198: 0.25% estimated exploitation activity in the next 30 days; percentile 16.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Pterodactyl implements rate limits that are applied to the total number of resources (e.g. databases, port allocations, or backups) that can exist for an individual server. These resource limits are applied on a per-server basis, and validated during the request cycle. However, it is possible for a malicious user to send a massive volume of requests at the same time that would create more resources than the server is allotted. This is because the validation occurs early in the request cycle and does not lock the target resource while it is processing. As a result sending a large volume of requests at the same time would lead all of those requests to validate as not using any of the target resources, and then all creating the resources at the same time. As a result a server would be able to create more databases, allocations, or backups than configured. Impact A malicious user is able to deny resources to other users on the system, and may be able to excessively consume the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jw2v-cq5x-q68g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-69198 Advisory: Pterodactyl improperly locks resources allowing raced queries to create more resources than alloted IDs: CVE-2025-69198, GHSA-jw2v-cq5x-q68g Record: https://patchnext.com/advisories/cve-2025-69198 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pterodactyl/panel 1.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pterodactyl/panel: affected < 1.12.0; fixed in 1.12.0 ## Suggested inspection (read-only) - Packagist pterodactyl/panel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pterodactyl/panel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jw2v-cq5x-q68g (GitHub-reviewed advisory GHSA-jw2v-cq5x-q68g lists affected ranges: Packagist pterodactyl/panel >=0 <1.12.0) Commands are suggestions: review each one before running it.
Loading voting…