Skip to content

← Actionable
Medium, CVSS 6.5

Pterodactyl TOTPs can be reused during validity window

CVE-2025-69197GHSA-rgmp-4873-r683

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pterodactyl/panel 1.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-69197: 0.36% estimated exploitation activity in the next 30 days; percentile 29.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When a user signs into an account with 2FA enabled they are prompted to enter a token. When that token is used, it is not sufficiently marked as used in the system allowing an attacker that intercepts that token to then use it in addition to a known username/password during the token validity window. This vulnerability requires that an attacker already be in possession of a valid username and password combination, and intercept a valid 2FA token (for example, during a screen share). The token must then be provided in addition to the username and password during the limited token validity window. The validity window is ~60 seconds as the Panel allows at most one additional window to the current one, each window being 30 seconds.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rgmp-4873-r683

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-69197

Advisory: Pterodactyl TOTPs can be reused during validity window
IDs: CVE-2025-69197, GHSA-rgmp-4873-r683
Record: https://patchnext.com/advisories/cve-2025-69197 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pterodactyl/panel 1.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pterodactyl/panel: affected < 1.12.0; fixed in 1.12.0

## Suggested inspection (read-only)
- Packagist pterodactyl/panel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pterodactyl/panel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rgmp-4873-r683 (GitHub-reviewed advisory GHSA-rgmp-4873-r683 lists affected ranges: Packagist pterodactyl/panel >=0 <1.12.0)

Commands are suggestions: review each one before running it.

Loading voting…