Skip to content

← Actionable
High, CVSS 7.4amended

FastMCP OAuth Proxy token reuse across MCP servers

CVE-2025-69196GHSA-5h2m-4q8j-pqpj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastmcp 2.14.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI fastmcp

    Affected
    < 2.14.2
    Fixed in
    2.14.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.4 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-69196: 0.38% estimated exploitation activity in the next 30 days; percentile 32.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

While testing the OAuth Proxy implementation, it was noticed that the server does not properly respect the resource parameter submitted by the client in the authorization and token request. Instead of issuing the token explicitly for this MCP server, the token is issued for the baseurl passed to the OAuthProxy during initialization. Affected File: https://github.com/jlowin/fastmcp/blob/main/src/fastmcp/server/auth/oauthproxy.py#L828 Affected Code: Since the issued access and refresh tokens do not include information about the resource the token was issued for, it is impossible for the MCP server to properly verify whether the token was issued for it, hence violating the requirement of doing so demanded by the specification. Being able to verify whether the token was issued for the target MCP server enforces the protections offered by the steps proposed by the specification and the Resource Indicators OAuth extension. Therefore, this misconfiguration exposes all MCP server setups…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5h2m-4q8j-pqpj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5h2m-4q8j-pqpj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-69196

Advisory: FastMCP OAuth Proxy token reuse across MCP servers
IDs: CVE-2025-69196, GHSA-5h2m-4q8j-pqpj
Record: https://patchnext.com/advisories/cve-2025-69196 (revision 3, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastmcp 2.14.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fastmcp: affected < 2.14.2; fixed in 2.14.2

## Suggested inspection (read-only)
- `python -m pip show fastmcp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastmcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5h2m-4q8j-pqpj (OSV record GHSA-5h2m-4q8j-pqpj lists affected ranges: PyPI fastmcp >=0 <2.14.2 (fixed))
- Verified: https://github.com/advisories/GHSA-5h2m-4q8j-pqpj (GitHub-reviewed advisory GHSA-5h2m-4q8j-pqpj lists affected ranges: PyPI fastmcp >=0 <2.14.2)

Commands are suggestions: review each one before running it.

Loading voting…