Skip to content

← Actionable
Medium, CVSS 5.4

phpMyFAQ has Stored XSS in user list via admin-managed display_name

CVE-2025-68951GHSA-jv8r-hv7q-p6vc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (thorsten/phpmyfaq 4.0.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-68951: 0.28% estimated exploitation activity in the next 30 days; percentile 20.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A stored cross-site scripting (XSS) vulnerability allows an attacker to execute arbitrary JavaScript in an administrator’s browser by registering a user whose display name contains HTML entities (e.g., <img ...>). When an administrator views the admin user list, the payload is decoded server-side and rendered without escaping, resulting in script execution in the admin context. Details Root cause is the following chain: - User-controlled input stored: attacker-provided displayname (real name) is stored in DB (often as HTML entities, e.g., <img ...>). - Decode on read: phpmyfaq/src/phpMyFAQ/User/UserData.php decodes displayname using htmlentitydecode(...) (“for backward compatibility”). - Unsafe sink: admin user list renders the decoded value unescaped using Twig |raw: - phpmyfaq/assets/templates/admin/user/users.twig (users table uses {{ user.displayname|raw }}) As a result, an entity-encoded payload becomes active HTML/JS when rendered in the admin user list.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jv8r-hv7q-p6vc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68951

Advisory: phpMyFAQ has Stored XSS in user list via admin-managed display_name
IDs: CVE-2025-68951, GHSA-jv8r-hv7q-p6vc
Record: https://patchnext.com/advisories/cve-2025-68951 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: thorsten/phpmyfaq 4.0.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist thorsten/phpmyfaq: affected >= 4.0.14, < 4.0.16; fixed in 4.0.16

## Suggested inspection (read-only)
- Packagist thorsten/phpmyfaq: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on thorsten/phpmyfaq.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jv8r-hv7q-p6vc (GitHub-reviewed advisory GHSA-jv8r-hv7q-p6vc lists affected ranges: Packagist thorsten/phpmyfaq >=4.0.14 <4.0.16)

Commands are suggestions: review each one before running it.

Loading voting…