n8n: Webhook Node IP Whitelist Bypass via Partial String Matching
CVE-2025-68949GHSA-w96v-gf22-crwp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- >= 1.36.0, < 2.2.0
- Fixed in
- 2.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w96v-gf22-crwp lists affected ranges: npm n8n >=1.36.0 <2.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w96v-gf22-crwp lists affected ranges: npm n8n >=1.36.0 <2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-68949: 0.30% estimated exploitation activity in the next 30 days; percentile 22.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Webhook node’s IP whitelist validation performed partial string matching instead of exact IP comparison. As a result, an incoming request could be accepted if the source IP address merely contained the configured whitelist entry as a substring. This issue affected instances where workflow editors relied on IP-based access controls to restrict webhook access. Both IPv4 and IPv6 addresses were impacted. An attacker with a non-whitelisted IP could bypass restrictions if their IP shared a partial prefix with a trusted address, undermining the intended security boundary. Patches This issue has been patched in version 2.2.0. Users are advised to upgrade to v2.2.0 or later, where IP whitelist validation uses strict IP comparison logic rather than partial string matching. Workarounds Users unable to upgrade immediately should avoid relying solely on IP whitelisting for webhook security. Recommended mitigations include: - Adding authentication mechanisms such as shared secrets,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w96v-gf22-crwp
- Revision 1 · created ·
Published from osv record GHSA-w96v-gf22-crwp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68949 Advisory: n8n: Webhook Node IP Whitelist Bypass via Partial String Matching IDs: CVE-2025-68949, GHSA-w96v-gf22-crwp Record: https://patchnext.com/advisories/cve-2025-68949 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected >= 1.36.0, < 2.2.0; fixed in 2.2.0 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w96v-gf22-crwp (OSV record GHSA-w96v-gf22-crwp lists affected ranges: npm n8n >=1.36.0 <2.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-w96v-gf22-crwp (GitHub-reviewed advisory GHSA-w96v-gf22-crwp lists affected ranges: npm n8n >=1.36.0 <2.2.0) Commands are suggestions: review each one before running it.
Loading voting…