Skip to content

← Actionable
High, CVSS 7.1amended

Self-hosted n8n has Legacy Code node that enables arbitrary file read/write

CVE-2025-68697GHSA-j4p8-h8mh-rh8q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 1.2.1, < 2.0.0
    Fixed in
    2.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
EPSS
  • CVE-2025-68697: 0.27% estimated exploitation activity in the next 30 days; percentile 18.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In self-hosted n8n instances where the Code node runs in legacy (non-task-runner) JavaScript execution mode, authenticated users with workflow editing access can invoke internal helper functions from within the Code node. This allows a workflow editor to perform actions on the n8n host with the same privileges as the n8n process, including: - Reading files from the host filesystem (subject to any file-access restrictions configured on the instance and OS/container permissions) - Writing files to the host filesystem (subject to the same restrictions) Starting with n8n version 1.2.1, access to files in the n8n home directory (.n8n) is blocked by default. However, this does not restrict access to other parts of the filesystem unless additional file access limitations are configured. Patches - Upgrade to n8n version 2.0.0 or later, where task runners are enabled by default for Code node execution. - On n8n version 1.71.0 and above, enable task runners by setting…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j4p8-h8mh-rh8q

  2. Revision 1 · created ·

    Published from osv record GHSA-j4p8-h8mh-rh8q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68697

Advisory: Self-hosted n8n has Legacy Code node that enables arbitrary file read/write
IDs: CVE-2025-68697, GHSA-j4p8-h8mh-rh8q
Record: https://patchnext.com/advisories/cve-2025-68697 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 1.2.1, < 2.0.0; fixed in 2.0.0

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j4p8-h8mh-rh8q (OSV record GHSA-j4p8-h8mh-rh8q lists affected ranges: npm n8n >=1.2.1 <2.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-j4p8-h8mh-rh8q (GitHub-reviewed advisory GHSA-j4p8-h8mh-rh8q lists affected ranges: npm n8n >=1.2.1 <2.0.0)

Commands are suggestions: review each one before running it.

Loading voting…