httparty Has Potential SSRF Vulnerability That Leads to API Key Leakage
CVE-2025-68696GHSA-hm5p-x4rq-38w4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (httparty 0.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems httparty
- Affected
- <= 0.23.2
- Fixed in
- 0.24.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hm5p-x4rq-38w4 lists affected ranges: RubyGems httparty >=0 <=0.23.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-68696: 0.30% estimated exploitation activity in the next 30 days; percentile 23.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There may be an SSRF vulnerability in httparty. This issue can pose a risk of leaking API keys, and it can also allow third parties to issue requests to internal servers. Details When httparty receives a path argument that is an absolute URL, it ignores the baseuri field. As a result, if a malicious user can control the path value, the application may unintentionally communicate with a host that the programmer did not anticipate. Consider the following example of a web application: Now, suppose an attacker sends a request like this: In this case, httparty sends the X-API-KEY not to http://example.test but instead to http://attacker.test. A similar problem was reported and fixed in the HTTP client library axios in the past: <https://github.com/axios/axios/issues/6463 Also, Python's urljoin function has documented a warning about similar behavior: <https://docs.python.org/3.13/library/urllib.parse.html#urllib.parse.urljoin PoC Follow these steps to reproduce the issue: 1. Set…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hm5p-x4rq-38w4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68696 Advisory: httparty Has Potential SSRF Vulnerability That Leads to API Key Leakage IDs: CVE-2025-68696, GHSA-hm5p-x4rq-38w4 Record: https://patchnext.com/advisories/cve-2025-68696 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: httparty 0.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems httparty: affected <= 0.23.2; fixed in 0.24.0 ## Suggested inspection (read-only) - RubyGems httparty: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on httparty. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hm5p-x4rq-38w4 (GitHub-reviewed advisory GHSA-hm5p-x4rq-38w4 lists affected ranges: RubyGems httparty >=0 <=0.23.2) Commands are suggestions: review each one before running it.
Loading voting…