Skip to content

← Actionable
Critical, CVSS 9.9amended

n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node

CVE-2025-68668GHSA-62r4-hw23-cc8v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 1.0.0, < 2.0.0
    Fixed in
    2.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L
EPSS
  • CVE-2025-68668: 13.17% estimated exploitation activity in the next 30 days; percentile 96.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A sandbox bypass vulnerability exists in the Python Code Node that uses Pyodide. An authenticated user with permission to create or modify workflows can exploit this vulnerability to execute arbitrary commands on the host system running n8n, using the same privileges as the n8n process. Patches In n8n version 1.111.0, a task-runner-based native Python implementation was introduced as an optional feature, providing a more secure isolation model. To enable it, you need to configure the N8NRUNNERSENABLED and N8NNATIVEPYTHONRUNNER environment variables. This implementation became the default starting with n8n version 2.0.0. Workarounds - Disable the Code Node by setting the environment variable NODESEXCLUDE: "[\"n8n-nodes-base.code\"]" (Docs) - Disable Python support in the Code node by setting the environment variable N8NPYTHONENABLED=false, which was introduced in n8n version 1.104.0. - Configure n8n to use the task runner based Python sandbox via the N8NRUNNERSENABLED and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-62r4-hw23-cc8v

  2. Revision 2 · amended ·

    Amended from osv record GHSA-62r4-hw23-cc8v

  3. Revision 1 · created ·

    Published from ghsa record GHSA-62r4-hw23-cc8v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68668

Advisory: n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
IDs: CVE-2025-68668, GHSA-62r4-hw23-cc8v
Record: https://patchnext.com/advisories/cve-2025-68668 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 1.0.0, < 2.0.0; fixed in 2.0.0

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-62r4-hw23-cc8v (GitHub-reviewed advisory GHSA-62r4-hw23-cc8v lists affected ranges: npm n8n >=1.0.0 <2.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-62r4-hw23-cc8v (OSV record GHSA-62r4-hw23-cc8v lists affected ranges: npm n8n >=1.0.0 <2.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…