LangChain serialization injection vulnerability enables secret extraction
CVE-2025-68665GHSA-r399-636x-v7f6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@langchain/core 1.1.8, 0.3.80; langchain 1.2.3, 0.3.37), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @langchain/core
- Affected
- >= 1.0.0, < 1.1.8< 0.3.80
- Fixed in
- 1.1.8, 0.3.80
npm langchain
- Affected
- >= 1.0.0, < 1.2.3< 0.3.37
- Fixed in
- 1.2.3, 0.3.37
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r399-636x-v7f6 lists affected ranges: npm @langchain/core >=1.0.0 =0 =1.0.0 =0 <0.3.37 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r399-636x-v7f6 lists affected ranges: npm @langchain/core >=1.0.0 =0 =1.0.0 =0 <0.3.37
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2025-68665: 0.79% estimated exploitation activity in the next 30 days; percentile 56.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Context A serialization injection vulnerability exists in LangChain JS's toJSON() method (and subsequently when string-ifying objects using JSON.stringify(). The method did not escape objects with 'lc' keys when serializing free-form data in kwargs. The 'lc' key is used internally by LangChain to mark serialized objects. When user-controlled data contains this key structure, it is treated as a legitimate LangChain object during deserialization rather than plain user data. Attack surface The core vulnerability was in Serializable.toJSON(): this method failed to escape user-controlled objects containing 'lc' keys within kwargs (e.g., additionalkwargs, metadata, responsemetadata). When this unescaped data was later deserialized via load(), the injected structures were treated as legitimate LangChain objects rather than plain user data. This escaping bug enabled several attack vectors: 1. Injection via user data: Malicious LangChain object structures could be injected through…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r399-636x-v7f6
- Revision 1 · created ·
Published from osv record GHSA-r399-636x-v7f6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68665 Advisory: LangChain serialization injection vulnerability enables secret extraction IDs: CVE-2025-68665, GHSA-r399-636x-v7f6 Record: https://patchnext.com/advisories/cve-2025-68665 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @langchain/core 1.1.8, 0.3.80; langchain 1.2.3, 0.3.37. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @langchain/core: affected >= 1.0.0, < 1.1.8; < 0.3.80; fixed in 1.1.8, 0.3.80 - npm langchain: affected >= 1.0.0, < 1.2.3; < 0.3.37; fixed in 1.2.3, 0.3.37 ## Suggested inspection (read-only) - `npm ls @langchain/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls langchain --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @langchain/core, langchain. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r399-636x-v7f6 (OSV record GHSA-r399-636x-v7f6 lists affected ranges: npm @langchain/core >=1.0.0 =0 =1.0.0 =0 <0.3.37 (fixed)) - Verified: https://github.com/advisories/GHSA-r399-636x-v7f6 (GitHub-reviewed advisory GHSA-r399-636x-v7f6 lists affected ranges: npm @langchain/core >=1.0.0 =0 =1.0.0 =0 <0.3.37) Commands are suggestions: review each one before running it.
Loading voting…