Skip to content

← Actionable
High, CVSS 7.3amended

Signal K Server Vulnerable to Remote Code Execution via Malicious npm Package

CVE-2025-68619GHSA-93jc-vqqc-vvvh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (signalk-server 2.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-68619: 0.71% estimated exploitation activity in the next 30 days; percentile 53.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The SignalK appstore interface allows administrators to install npm packages through a REST API endpoint. While the endpoint validates that the package name exists in the npm registry as a known plugin or webapp, the version parameter accepts arbitrary npm version specifiers including URLs. npm supports installing packages from git repositories, GitHub shorthand syntax, and HTTP/HTTPS URLs pointing to tarballs. When npm installs a package, it can automatically execute any postinstall script defined in package.json, enabling arbitrary code execution. The vulnerability exists because npm's version specifier syntax is extremely flexible, and the SignalK code passes the version parameter directly to npm without sanitization. An attacker with admin access can install a package from an attacker-controlled source containing a malicious postinstall script. Affected Code File: src/interfaces/appstore.js (lines 46-76) File: src/modules.ts (lines 180-205) Impact An attacker with admin…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-93jc-vqqc-vvvh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-93jc-vqqc-vvvh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68619

Advisory: Signal K Server Vulnerable to Remote Code Execution via Malicious npm Package
IDs: CVE-2025-68619, GHSA-93jc-vqqc-vvvh
Record: https://patchnext.com/advisories/cve-2025-68619 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: signalk-server 2.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm signalk-server: affected < 2.9.0; fixed in 2.9.0

## Suggested inspection (read-only)
- `npm ls signalk-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on signalk-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-93jc-vqqc-vvvh (OSV record GHSA-93jc-vqqc-vvvh lists affected ranges: npm signalk-server >=0 <2.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-93jc-vqqc-vvvh (GitHub-reviewed advisory GHSA-93jc-vqqc-vvvh lists affected ranges: npm signalk-server >=0 <2.9.0)

Commands are suggestions: review each one before running it.

Loading voting…