n8n Vulnerable to Remote Code Execution via Expression Injection
CVE-2025-68613GHSA-v98v-ff95-f3cp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.121.1, 1.120.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- >= 0.211.0, < 1.120.4>= 1.121.0, < 1.121.1
- Fixed in
- 1.121.1, 1.120.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v98v-ff95-f3cp lists affected ranges: npm n8n >=0.211.0 =1.121.0 <1.121.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2025-68613 to the Known Exploited Vulnerabilities catalog on 2026-03-11.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2026-03-11).
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v98v-ff95-f3cp lists affected ranges: npm n8n >=0.211.0 =1.121.0 <1.121.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-68613: 98.99% estimated exploitation activity in the next 30 days; percentile 99.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact n8n contains a critical Remote Code Execution (RCE) vulnerability in its workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. Patches This issue has been fixed in n8n v1.122.0. Users are strongly advised to upgrade to version 1.122.0 or later, which introduces additional safeguards to restrict expression evaluation. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v98v-ff95-f3cp
- Revision 2 · amended ·
Amended from osv record GHSA-v98v-ff95-f3cp
- Revision 1 · created ·
Published from ghsa record GHSA-v98v-ff95-f3cp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68613 Advisory: n8n Vulnerable to Remote Code Execution via Expression Injection IDs: CVE-2025-68613, GHSA-v98v-ff95-f3cp Record: https://patchnext.com/advisories/cve-2025-68613 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: n8n 1.121.1, 1.120.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected >= 0.211.0, < 1.120.4; >= 1.121.0, < 1.121.1; fixed in 1.121.1, 1.120.4 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v98v-ff95-f3cp (GitHub-reviewed advisory GHSA-v98v-ff95-f3cp lists affected ranges: npm n8n >=0.211.0 =1.121.0 <1.121.1) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-68613 to the Known Exploited Vulnerabilities catalog on 2026-03-11.) - Verified: https://osv.dev/vulnerability/GHSA-v98v-ff95-f3cp (OSV record GHSA-v98v-ff95-f3cp lists affected ranges: npm n8n >=0.211.0 =1.121.0 <1.121.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…