Skip to content

← Actionable
Medium, CVSS 5.9amended

FastAPI Users Vulnerable to 1-click Account Takeover in Apps Using FastAPI SSO

CVE-2025-68481GHSA-5j53-63w8-8625

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastapi-users 15.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N
EPSS
  • CVE-2025-68481: 0.26% estimated exploitation activity in the next 30 days; percentile 17.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The OAuth login state tokens are completely stateless and carry no per-request entropy or any data that could link them to the session that initiated the OAuth flow. generatestatetoken() is always called with an empty statedata dict, so the resulting JWT only contains the fixed audience claim plus an expiration timestamp. \[1\] fastapi\users/router/oauth.py:65-71 On callback, the library merely checks that the JWT verifies under statesecret and is unexpired; there is no attempt to match the state value to the browser that initiated the OAuth request, no correlation cookie, and no server-side cache. \[2\] fastapi\users/router/oauth.py:130-141 Any attacker can hit /authorize, capture the server-generated state, finish the upstream OAuth flow with their own provider account, and then trick a victim into loading .../callback?code=<attackercode&state=<attackerstate. Because the state JWT is valid for any client for \~1 hour, the victim’s browser will complete the flow. This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5j53-63w8-8625

  2. Revision 1 · created ·

    Published from osv record GHSA-5j53-63w8-8625

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68481

Advisory: FastAPI Users Vulnerable to 1-click Account Takeover in Apps Using FastAPI SSO
IDs: CVE-2025-68481, GHSA-5j53-63w8-8625
Record: https://patchnext.com/advisories/cve-2025-68481 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastapi-users 15.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fastapi-users: affected < 15.0.2; fixed in 15.0.2

## Suggested inspection (read-only)
- `python -m pip show fastapi-users`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastapi-users.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5j53-63w8-8625 (OSV record GHSA-5j53-63w8-8625 lists affected ranges: PyPI fastapi-users >=0 <15.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-5j53-63w8-8625 (GitHub-reviewed advisory GHSA-5j53-63w8-8625 lists affected ranges: PyPI fastapi-users >=0 <15.0.2)

Commands are suggestions: review each one before running it.

Loading voting…