External Control of File Name or Path in Langflow
CVE-2025-68478GHSA-f43r-cc68-gpx4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.7.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langflow
- Affected
- < 1.7.1
- Fixed in
- 1.7.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f43r-cc68-gpx4 lists affected ranges: PyPI langflow >=0 <1.7.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f43r-cc68-gpx4 lists affected ranges: PyPI langflow >=0 <1.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
- EPSS
- CVE-2025-68478: 5.79% estimated exploitation activity in the next 30 days; percentile 93.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability Overview If an arbitrary path is specified in the request body's fspath, the server serializes the Flow object into JSON and creates/overwrites a file at that path. There is no path restriction, normalization, or allowed directory enforcement, so absolute paths (e.g., /etc/poc.txt) are interpreted as is. Vulnerable Code 1. It receives the request body (flow), updates the DB, and then passes it to the file-writing sink. https://github.com/langflow-ai/langflow/blob/ac6e2d2eabeee28085f2739d79f7ce4205ca082c/src/backend/base/langflow/api/v1/flows.py#L154-L168 2. Applies authentication dependency (requires API Key/JWT) when accessing the endpoint. https://github.com/langflow-ai/langflow/blob/ac6e2d2eabeee28085f2739d79f7ce4205ca082c/src/backend/base/langflow/api/utils/core.py#L36-L38 3. The client can directly specify the save path, including fspath.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f43r-cc68-gpx4
- Revision 1 · created ·
Published from osv record GHSA-f43r-cc68-gpx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68478 Advisory: External Control of File Name or Path in Langflow IDs: CVE-2025-68478, GHSA-f43r-cc68-gpx4 Record: https://patchnext.com/advisories/cve-2025-68478 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langflow 1.7.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langflow: affected < 1.7.1; fixed in 1.7.1 ## Suggested inspection (read-only) - `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f43r-cc68-gpx4 (OSV record GHSA-f43r-cc68-gpx4 lists affected ranges: PyPI langflow >=0 <1.7.1 (fixed)) - Verified: https://github.com/advisories/GHSA-f43r-cc68-gpx4 (GitHub-reviewed advisory GHSA-f43r-cc68-gpx4 lists affected ranges: PyPI langflow >=0 <1.7.1) Commands are suggestions: review each one before running it.
Loading voting…