Fedify has ReDoS Vulnerability in HTML Parsing Regex
CVE-2025-68475GHSA-rchf-xwx2-hm93
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fedify/fedify 1.9.2, 1.8.15, 1.7.14, 1.6.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @fedify/fedify
- Affected
- < 1.6.13>= 1.7.0, < 1.7.14>= 1.8.0, < 1.8.15>= 1.9.0, < 1.9.2
- Fixed in
- 1.7.14, 1.9.2, 1.8.15, 1.6.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rchf-xwx2-hm93 lists affected ranges: npm @fedify/fedify >=0 =1.7.0 =1.8.0 =1.9.0 <1.9.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rchf-xwx2-hm93 lists affected ranges: npm @fedify/fedify >=0 =1.7.0 =1.8.0 =1.9.0 <1.9.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-68475: 0.56% estimated exploitation activity in the next 30 days; percentile 46.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Hi Fedify team! 👋 Thank you for your work on Fedify—it's a fantastic library for building federated applications. While reviewing the codebase, I discovered a Regular Expression Denial of Service (ReDoS) vulnerability that I'd like to report. I hope this helps improve the project's security. --- Summary A Regular Expression Denial of Service (ReDoS) vulnerability exists in Fedify's document loader. The HTML parsing regex at packages/fedify/src/runtime/docloader.ts:259 contains nested quantifiers that cause catastrophic backtracking when processing maliciously crafted HTML responses. An attacker-controlled federated server can respond with a small (~170 bytes) malicious HTML payload that blocks the victim's Node.js event loop for 14+ seconds, causing a Denial of Service. | Field | Value | |-------|-------| | CWE | CWE-1333 (Inefficient Regular Expression Complexity) | --- Details Vulnerable Code The vulnerability is located in packages/fedify/src/runtime/docloader.ts, lines 258-264:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rchf-xwx2-hm93
- Revision 1 · created ·
Published from osv record GHSA-rchf-xwx2-hm93
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68475 Advisory: Fedify has ReDoS Vulnerability in HTML Parsing Regex IDs: CVE-2025-68475, GHSA-rchf-xwx2-hm93 Record: https://patchnext.com/advisories/cve-2025-68475 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fedify/fedify 1.9.2, 1.8.15, 1.7.14, 1.6.13. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fedify/fedify: affected < 1.6.13; >= 1.7.0, < 1.7.14; >= 1.8.0, < 1.8.15; >= 1.9.0, < 1.9.2; fixed in 1.7.14, 1.9.2, 1.8.15, 1.6.13 ## Suggested inspection (read-only) - `npm ls @fedify/fedify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fedify/fedify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rchf-xwx2-hm93 (OSV record GHSA-rchf-xwx2-hm93 lists affected ranges: npm @fedify/fedify >=0 =1.7.0 =1.8.0 =1.9.0 <1.9.2 (fixed)) - Verified: https://github.com/advisories/GHSA-rchf-xwx2-hm93 (GitHub-reviewed advisory GHSA-rchf-xwx2-hm93 lists affected ranges: npm @fedify/fedify >=0 =1.7.0 =1.8.0 =1.9.0 <1.9.2) Commands are suggestions: review each one before running it.
Loading voting…