Skip to content

← Actionable
Medium, CVSS 6.5amended

React Router has unexpected external redirect via untrusted paths

CVE-2025-68470GHSA-9jcx-v3wj-wh4m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-router 7.9.6, 6.30.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm react-router

    Affected
    >= 6.0.0, < 6.30.2>= 7.0.0, < 7.9.6
    Fixed in
    7.9.6, 6.30.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2025-68470: 0.49% estimated exploitation activity in the next 30 days; percentile 42.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An attacker-supplied path can be crafted so that when a React Router application navigates to it via navigate(), <Link, or redirect(), the app performs a navigation/redirect to an external URL. This is only an issue if developers pass untrusted content into navigation paths in their application code.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9jcx-v3wj-wh4m

  2. Revision 1 · created ·

    Published from osv record GHSA-9jcx-v3wj-wh4m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68470

Advisory: React Router has unexpected external redirect via untrusted paths
IDs: CVE-2025-68470, GHSA-9jcx-v3wj-wh4m
Record: https://patchnext.com/advisories/cve-2025-68470 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: react-router 7.9.6, 6.30.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm react-router: affected >= 6.0.0, < 6.30.2; >= 7.0.0, < 7.9.6; fixed in 7.9.6, 6.30.2

## Suggested inspection (read-only)
- `npm ls react-router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on react-router.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9jcx-v3wj-wh4m (OSV record GHSA-9jcx-v3wj-wh4m lists affected ranges: npm react-router >=6.0.0 =7.0.0 <7.9.6 (fixed))
- Verified: https://github.com/advisories/GHSA-9jcx-v3wj-wh4m (GitHub-reviewed advisory GHSA-9jcx-v3wj-wh4m lists affected ranges: npm react-router >=6.0.0 =7.0.0 <7.9.6)

Commands are suggestions: review each one before running it.

Loading voting…