Dark Reader gives users the ability to request style sheets from local web servers
CVE-2025-68467GHSA-x369-mcw8-8rvj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (darkreader 4.9.117), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm darkreader
- Affected
- < 4.9.117
- Fixed in
- 4.9.117
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x369-mcw8-8rvj lists affected ranges: npm darkreader >=0 <4.9.117 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x369-mcw8-8rvj lists affected ranges: npm darkreader >=0 <4.9.117
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
- EPSS
- CVE-2025-68467: 0.13% estimated exploitation activity in the next 30 days; percentile 2.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Dark Reader versions prior to 4.9.117 included a behavior where a website could request a style sheet from a locally running web server, for example http://localhost:8080/style.css, If an address was available and returned a text/css content type. Patches The problem was fixed in version 4.9.117, released on December 3, 2025. Most users received the update automatically. Users running manual builds must upgrade to version 4.9.117 or later. The installed extension version number can be verified in Dark Reader's menu (More All settings About), browser settings, chrome://extensions or about:addons pages. Users are encouraged not to disable automatic extension updates and use the latest browser version, as browser releases typically include multiple security fixes of varying severity. NPM package The issue does not affect developers using the darkreader NPM package for website integration. Developers using the setFetchMethod() API must ensure the cross-origin requests are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x369-mcw8-8rvj
- Revision 1 · created ·
Published from osv record GHSA-x369-mcw8-8rvj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68467 Advisory: Dark Reader gives users the ability to request style sheets from local web servers IDs: CVE-2025-68467, GHSA-x369-mcw8-8rvj Record: https://patchnext.com/advisories/cve-2025-68467 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: darkreader 4.9.117. A vendor fix does not mean a deployment is fixed. ## Affected components - npm darkreader: affected < 4.9.117; fixed in 4.9.117 ## Suggested inspection (read-only) - `npm ls darkreader --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on darkreader. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x369-mcw8-8rvj (OSV record GHSA-x369-mcw8-8rvj lists affected ranges: npm darkreader >=0 <4.9.117 (fixed)) - Verified: https://github.com/advisories/GHSA-x369-mcw8-8rvj (GitHub-reviewed advisory GHSA-x369-mcw8-8rvj lists affected ranges: npm darkreader >=0 <4.9.117) Commands are suggestions: review each one before running it.
Loading voting…