Skip to content

← Actionable
Low, CVSS 3.7amended

webpack buildHttp: allowedUris allow-list bypass via URL userinfo (@) leading to build-time SSRF behavior

CVE-2025-68458GHSA-8fgc-7cc6-rx7x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (webpack 5.104.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm webpack

    Affected
    >= 5.49.0, <= 5.104.0
    Fixed in
    5.104.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-68458: 0.23% estimated exploitation activity in the next 30 days; percentile 13.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When experiments.buildHttp is enabled, webpack’s HTTP(S) resolver (HttpUriPlugin) can be bypassed to fetch resources from hosts outside allowedUris by using crafted URLs that include userinfo (username:password@host). If allowedUris enforcement relies on a raw string prefix check (e.g., uri.startsWith(allowed)), a URL that looks allow-listed can pass validation while the actual network request is sent to a different authority/host after URL parsing. This is a policy/allow-list bypass that enables build-time SSRF behavior (outbound requests from the build machine to internal-only endpoints, depending on network access) and untrusted content inclusion (the fetched response is treated as module source and bundled). In my reproduction, the internal response was also persisted in the buildHttp cache. Reproduced on: - webpack version: 5.104.0 - Node version: v18.19.1 Details Root cause (high level): allowedUris validation can be performed on the raw URI string, while the actual…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8fgc-7cc6-rx7x

  2. Revision 1 · created ·

    Published from osv record GHSA-8fgc-7cc6-rx7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68458

Advisory: webpack buildHttp: allowedUris allow-list bypass via URL userinfo (@) leading to build-time SSRF behavior
IDs: CVE-2025-68458, GHSA-8fgc-7cc6-rx7x
Record: https://patchnext.com/advisories/cve-2025-68458 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: webpack 5.104.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm webpack: affected >= 5.49.0, <= 5.104.0; fixed in 5.104.1

## Suggested inspection (read-only)
- `npm ls webpack --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on webpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8fgc-7cc6-rx7x (OSV record GHSA-8fgc-7cc6-rx7x lists affected ranges: npm webpack >=5.49.0 <5.104.1 (fixed))
- Verified: https://github.com/advisories/GHSA-8fgc-7cc6-rx7x (GitHub-reviewed advisory GHSA-8fgc-7cc6-rx7x lists affected ranges: npm webpack >=5.49.0 <=5.104.0)

Commands are suggestions: review each one before running it.

Loading voting…