Skip to content

← Actionable
High, CVSS 7.0

Unauthenticated Craft CMS users can trigger a database backup

CVE-2025-68456GHSA-v64r-7wg9-23pr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.8.21, 4.16.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 5.0.0-RC1, <= 5.8.20>= 3.0.0, <= 4.16.16
    Fixed in
    4.16.17, 5.8.21

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-68456: 0.56% estimated exploitation activity in the next 30 days; percentile 46.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unauthenticated users can trigger database backup operations the updater/backup action, potentially leading to resource exhaustion or information disclosure. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue. Craft 3 users should update to the latest Craft 4 and 5 releases, which include the fixes. References: https://github.com/craftcms/cms/commit/f83d4e0c6b906743206b4747db4abf8164b8da39 https://github.com/craftcms/cms/blob/5.x/CHANGELOG.md#5821---2025-12-04 Affected Endpoints - POST /admin/actions/updater/backup (unauthenticated) Vulnerability Details Root Cause All updater/ actions are explicitly configured with anonymous access: Attack Vector 1. Send unauthenticated POST request to /admin/actions/updater/backup 2. Database backup executes with configured backupCommand

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v64r-7wg9-23pr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68456

Advisory: Unauthenticated Craft CMS users can trigger a database backup
IDs: CVE-2025-68456, GHSA-v64r-7wg9-23pr
Record: https://patchnext.com/advisories/cve-2025-68456 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.8.21, 4.16.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 5.0.0-RC1, <= 5.8.20; >= 3.0.0, <= 4.16.16; fixed in 4.16.17, 5.8.21

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v64r-7wg9-23pr (GitHub-reviewed advisory GHSA-v64r-7wg9-23pr lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =3.0.0 <=4.16.16)

Commands are suggestions: review each one before running it.

Loading voting…