Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI
CVE-2025-68454GHSA-742x-x762-7383
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.8.21, 4.16.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 5.0.0-RC1, <= 5.8.20>= 4.0.0-RC1, <= 4.16.16
- Fixed in
- 4.16.17, 5.8.21
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-742x-x762-7383 lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <=4.16.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-68454: 0.94% estimated exploitation activity in the next 30 days; percentile 61.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
For this to work, users must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled for this to work, which is against Craft CMS' recommendations for any non-dev environment. https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production Alternatively, a non-administrator account with allowAdminChanges disabled can be used, provided access to the System Messages utility is available. It is possible to craft a malicious payload using the Twig map filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue. References: https://github.com/craftcms/cms/commit/d82680f4a05f9576883bb83c3f6243d33ca73ebe https://github.com/craftcms/cms/blob/5.x/CHANGELOG.md#5821---2025-12-04
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-742x-x762-7383
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68454 Advisory: Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI IDs: CVE-2025-68454, GHSA-742x-x762-7383 Record: https://patchnext.com/advisories/cve-2025-68454 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.8.21, 4.16.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 5.0.0-RC1, <= 5.8.20; >= 4.0.0-RC1, <= 4.16.16; fixed in 4.16.17, 5.8.21 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-742x-x762-7383 (GitHub-reviewed advisory GHSA-742x-x762-7383 lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <=4.16.16) Commands are suggestions: review each one before running it.
Loading voting…