Skip to content

← Actionable
High, CVSS 7.3amended

Storybook manager bundle may expose environment variables during build

CVE-2025-68429GHSA-8452-54wp-rmv6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (storybook 10.1.10, 9.1.17, 8.6.15, 7.6.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm storybook

    Affected
    >= 7.0.0, < 7.6.21>= 8.0.0, < 8.6.15>= 9.0.0, < 9.1.17>= 10.0.0, < 10.1.10
    Fixed in
    10.1.10, 8.6.15, 7.6.21, 9.1.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2025-68429: 0.26% estimated exploitation activity in the next 30 days; percentile 17.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

On December 11th, the Storybook team received a responsible disclosure alerting them to a potential vulnerability in certain built and published Storybooks. The vulnerability is a bug in how Storybook handles environment variables defined in a .env file, which could, in specific circumstances, lead to those variables being unexpectedly bundled into the artifacts created by the storybook build command. When a built Storybook is published to the web, the bundle’s source is viewable, thus potentially exposing those variables to anyone with access. If those variables contained secrets, they should be considered compromised. Who is impacted? For a project to be vulnerable to this issue, it must: - Build the Storybook (i.e. run storybook build directly or indirectly) in a directory that contains a .env file (including variants like .env.local) - The .env file contains sensitive secrets - Use Storybook version 7.0.0 or above - Publish the built Storybook to the web Storybooks built without…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8452-54wp-rmv6

  2. Revision 1 · created ·

    Published from osv record GHSA-8452-54wp-rmv6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68429

Advisory: Storybook manager bundle may expose environment variables during build
IDs: CVE-2025-68429, GHSA-8452-54wp-rmv6
Record: https://patchnext.com/advisories/cve-2025-68429 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: storybook 10.1.10, 9.1.17, 8.6.15, 7.6.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm storybook: affected >= 7.0.0, < 7.6.21; >= 8.0.0, < 8.6.15; >= 9.0.0, < 9.1.17; >= 10.0.0, < 10.1.10; fixed in 10.1.10, 8.6.15, 7.6.21, 9.1.17

## Suggested inspection (read-only)
- `npm ls storybook --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on storybook.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8452-54wp-rmv6 (OSV record GHSA-8452-54wp-rmv6 lists affected ranges: npm storybook >=7.0.0 =8.0.0 =9.0.0 =10.0.0 <10.1.10 (fixed))
- Verified: https://github.com/advisories/GHSA-8452-54wp-rmv6 (GitHub-reviewed advisory GHSA-8452-54wp-rmv6 lists affected ranges: npm storybook >=7.0.0 =8.0.0 =9.0.0 =10.0.0 <10.1.10)

Commands are suggestions: review each one before running it.

Loading voting…