jsPDF has Local File Inclusion/Path Traversal vulnerability
CVE-2025-68428GHSA-f8cm-6447-x5h2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jspdf 4.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm jspdf
- Affected
- <= 3.0.4
- Fixed in
- 4.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f8cm-6447-x5h2 lists affected ranges: npm jspdf >=0 <=3.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f8cm-6447-x5h2 lists affected ranges: npm jspdf >=0 <4.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2025-68428: 2.18% estimated exploitation activity in the next 30 days; percentile 82.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact User control of the first argument of the loadFile method in the node.js build allows local file inclusion/path traversal. If given the possibility to pass unsanitized paths to the loadFile method, a user can retrieve file contents of arbitrary files in the local file system the node process is running in. The file contents are included verbatim in the generated PDFs. Other affected methods are: addImage, html, addFont. Only the node.js builds of the library are affected, namely the dist/jspdf.node.js and dist/jspdf.node.min.js files. Example attack vector: Patches The vulnerability has been fixed in jsPDF@4.0.0. This version restricts file system access per default. This semver-major update does not introduce other breaking changes. Workarounds With recent node versions, jsPDF recommends using the --permission flag in production. The feature was introduced experimentally in v20.0.0 and is stable since v22.13.0/v23.5.0/v24.0.0. See the node documentation for details. For older…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-f8cm-6447-x5h2
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-f8cm-6447-x5h2
- Revision 1 · created ·
Published from ghsa record GHSA-f8cm-6447-x5h2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68428 Advisory: jsPDF has Local File Inclusion/Path Traversal vulnerability IDs: CVE-2025-68428, GHSA-f8cm-6447-x5h2 Record: https://patchnext.com/advisories/cve-2025-68428 (revision 4, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jspdf 4.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jspdf: affected <= 3.0.4; fixed in 4.0.0 ## Suggested inspection (read-only) - `npm ls jspdf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jspdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f8cm-6447-x5h2 (GitHub-reviewed advisory GHSA-f8cm-6447-x5h2 lists affected ranges: npm jspdf >=0 <=3.0.4) - Verified: https://osv.dev/vulnerability/GHSA-f8cm-6447-x5h2 (OSV record GHSA-f8cm-6447-x5h2 lists affected ranges: npm jspdf >=0 <4.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…