Filebeat Beats has Buffer Overflow via Malformed Syslog Message or Malicious Tokenizer Pattern in Dissect Configuration
CVE-2025-68383GHSA-2mj3-6grc-px38
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/elastic/beats
- Affected
- <= 7.6.2
- Fixed in
- no fixed version recorded
Go github.com/elastic/beats/v7
- Affected
- >= 7.7.0, < 8.19.9>= 9.0.0, < 9.1.9>= 9.2.0, < 9.2.3< 7.0.0-alpha2.0.20251204214633-dd3af18220bf
- Fixed in
- 8.19.9, 7.0.0-alpha2.0.20251204214633-dd3af18220bf, 9.1.9, 9.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2mj3-6grc-px38 lists affected ranges: Go github.com/elastic/beats/v7 >=7.7.0 =9.0.0 =9.2.0 =0 =0 <=7.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-68383: 0.19% estimated exploitation activity in the next 30 days; percentile 8.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Validation of Specified Index, Position, or Offset in Input (CWE-1285) in Filebeat Syslog parser and the Libbeat Dissect processor can allow a user to trigger a Buffer Overflow (CAPEC-100) and cause a denial of service (panic/crash) of the Filebeat process via either a malformed Syslog message or a malicious tokenizer pattern in the Dissect configuration.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2mj3-6grc-px38
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68383 Advisory: Filebeat Beats has Buffer Overflow via Malformed Syslog Message or Malicious Tokenizer Pattern in Dissect Configuration IDs: CVE-2025-68383, GHSA-2mj3-6grc-px38 Record: https://patchnext.com/advisories/cve-2025-68383 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/elastic/beats/v7 9.2.3, 9.1.9, 8.19.9, 7.0.0-alpha2.0.20251204214633-dd3af18220bf. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/elastic/beats: affected <= 7.6.2 - Go github.com/elastic/beats/v7: affected >= 7.7.0, < 8.19.9; >= 9.0.0, < 9.1.9; >= 9.2.0, < 9.2.3; < 7.0.0-alpha2.0.20251204214633-dd3af18220bf; fixed in 8.19.9, 7.0.0-alpha2.0.20251204214633-dd3af18220bf, 9.1.9, 9.2.3 ## Suggested inspection (read-only) - Go github.com/elastic/beats: check the installed version with your package manager. - Go github.com/elastic/beats/v7: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/elastic/beats, github.com/elastic/beats/v7. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2mj3-6grc-px38 (GitHub-reviewed advisory GHSA-2mj3-6grc-px38 lists affected ranges: Go github.com/elastic/beats/v7 >=7.7.0 =9.0.0 =9.2.0 =0 =0 <=7.6.2) Commands are suggestions: review each one before running it.
Loading voting…