Skip to content

← Actionable
High, CVSS 7.3amended

tinacms is vulnerable to arbitrary code execution

CVE-2025-68278GHSA-529f-9qwm-9628

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@tinacms/graphql 2.0.3; tinacms 3.1.1; @tinacms/cli 2.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-68278: 0.48% estimated exploitation activity in the next 30 days; percentile 41.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary uses the package in an insecure way allowing attackers that can control the content of the processed markdown files, e.g., blog posts, to execute arbitrary code. Details The package executes by default the code in the markdown file's front matter. does not change this behavior when process markdown file, e.g., by passing a custom engine property for js/javascript in the options object. PoC 1. Create a tinacms app using the cli/documentation: 2. Modify one of the blog posts to contain the following front matter: 3. Start the tinacms server, e.g., with 4. Observe the console of the server printing the password file, showing that attackers can execute arbitrary commands. Impact RCE: attackers can execute arbitrary JavaScript code on the server hosting tinacms. Feasibility Potential attack scenarios can be executed like this: Companies often have technical writers as contractors. These contractors produce md files, which they send over email or upload in a shared cloud folder.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-529f-9qwm-9628

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-529f-9qwm-9628

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68278

Advisory: tinacms is vulnerable to arbitrary code execution
IDs: CVE-2025-68278, GHSA-529f-9qwm-9628
Record: https://patchnext.com/advisories/cve-2025-68278 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @tinacms/graphql 2.0.3; tinacms 3.1.1; @tinacms/cli 2.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @tinacms/graphql: affected < 2.0.3; fixed in 2.0.3
- npm tinacms: affected < 3.1.1; fixed in 3.1.1
- npm @tinacms/cli: affected < 2.0.4; fixed in 2.0.4

## Suggested inspection (read-only)
- `npm ls @tinacms/graphql --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls tinacms --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @tinacms/cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @tinacms/graphql, tinacms, @tinacms/cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-529f-9qwm-9628 (OSV record GHSA-529f-9qwm-9628 lists affected ranges: npm tinacms >=0 =0 =0 <2.0.3 (fixed))
- Verified: https://github.com/advisories/GHSA-529f-9qwm-9628 (GitHub-reviewed advisory GHSA-529f-9qwm-9628 lists affected ranges: npm tinacms >=0 =0 =0 <2.0.3)

Commands are suggestions: review each one before running it.

Loading voting…