Skip to content

← Actionable
Medium, CVSS 5.3amended

Signal K Server Vulnerable to Unauthenticated Information Disclosure via Exposed Endpoints

CVE-2025-68273GHSA-fpf5-w967-rr2m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (signalk-server 2.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-68273: 0.82% estimated exploitation activity in the next 30 days; percentile 57.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

[Note] This is a separate issue from the RCE vulnerability (State Pollution) currently being patched. While related to tokensecurity.js, it involves different endpoints and risks. Summary An unauthenticated information disclosure vulnerability allows any user to retrieve sensitive system information, including the full SignalK data schema, connected serial devices, and installed analyzer tools. This exposure facilitates reconnaissance for further attacks. Details The vulnerability stems from the fact that several sensitive API endpoints are not included in the authentication middleware's protection list in src/tokensecurity.js. Vulnerable Code Analysis: 1. Missing Protection: The tokensecurity.js file defines an array of paths that require authentication. However, the following paths defined in src/serverroutes.ts are missing from this list: - /skServer/serialports - /skServer/availablePaths - /skServer/hasAnalyzer 2. Unrestricted Access: Because they are missing from the protection…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fpf5-w967-rr2m

  2. Revision 1 · created ·

    Published from osv record GHSA-fpf5-w967-rr2m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68273

Advisory: Signal K Server Vulnerable to Unauthenticated Information Disclosure via Exposed Endpoints
IDs: CVE-2025-68273, GHSA-fpf5-w967-rr2m
Record: https://patchnext.com/advisories/cve-2025-68273 (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: signalk-server 2.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm signalk-server: affected < 2.19.0; fixed in 2.19.0

## Suggested inspection (read-only)
- `npm ls signalk-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on signalk-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fpf5-w967-rr2m (OSV record GHSA-fpf5-w967-rr2m lists affected ranges: npm signalk-server >=0 <2.19.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fpf5-w967-rr2m (GitHub-reviewed advisory GHSA-fpf5-w967-rr2m lists affected ranges: npm signalk-server >=0 <2.19.0)

Commands are suggestions: review each one before running it.

Loading voting…