Skip to content

← Actionable
Critical, CVSS 10.0

openc3-api Vulnerable to Unauthenticated Remote Code Execution

CVE-2025-68271GHSA-w757-4qv9-mghp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openc3 6.10.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems openc3

    Affected
    >= 5.0.6, < 6.10.2
    Fixed in
    6.10.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-68271: 0.64% estimated exploitation activity in the next 30 days; percentile 50.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary OpenC3 COSMOS contains a critical remote code execution vulnerability reachable through the JSON-RPC API. When a JSON-RPC request uses the string form of certain APIs, attacker-controlled parameter text is parsed into values using String#converttovalue. For array-like inputs, converttovalue executes eval(). Because the cmd code path parses the command string before calling authorize(), an unauthenticated attacker can trigger Ruby code execution even though the request ultimately fails authorization (401).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w757-4qv9-mghp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68271

Advisory: openc3-api Vulnerable to Unauthenticated Remote Code Execution
IDs: CVE-2025-68271, GHSA-w757-4qv9-mghp
Record: https://patchnext.com/advisories/cve-2025-68271 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openc3 6.10.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems openc3: affected >= 5.0.6, < 6.10.2; fixed in 6.10.2

## Suggested inspection (read-only)
- RubyGems openc3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openc3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w757-4qv9-mghp (GitHub-reviewed advisory GHSA-w757-4qv9-mghp lists affected ranges: RubyGems openc3 >=5.0.6 <6.10.2)

Commands are suggestions: review each one before running it.

Loading voting…