systeminformation has a Command Injection vulnerability in fsSize() function on Windows
CVE-2025-68154GHSA-wphj-fx3q-84ch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (systeminformation 5.27.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 5.27.14
- Fixed in
- 5.27.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wphj-fx3q-84ch lists affected ranges: npm systeminformation >=0 <5.27.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wphj-fx3q-84ch lists affected ranges: npm systeminformation >=0 <5.27.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-68154: 12.99% estimated exploitation activity in the next 30 days; percentile 96.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The fsSize() function in systeminformation is vulnerable to OS Command Injection (CWE-78) on Windows systems. The optional drive parameter is directly concatenated into a PowerShell command without sanitization, allowing arbitrary command execution when user-controlled input reaches this function. Affected Platforms: Windows only CVSS Breakdown: - Attack Vector (AV:N): Network - if used in a web application/API - Attack Complexity (AC:H): High - requires application to pass user input to fsSize() - Privileges Required (PR:N): None - no authentication required at library level - User Interaction (UI:N): None - Scope (S:U): Unchanged - executes within Node.js process context - Confidentiality/Integrity/Availability (C:H/I:H/A:H): High impact if exploited Note: The actual exploitability depends on how applications use this function. If an application does not pass user-controlled input to fsSize(), it is not vulnerable. --- Details Vulnerable Code Location File:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wphj-fx3q-84ch
- Revision 1 · created ·
Published from osv record GHSA-wphj-fx3q-84ch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68154 Advisory: systeminformation has a Command Injection vulnerability in fsSize() function on Windows IDs: CVE-2025-68154, GHSA-wphj-fx3q-84ch Record: https://patchnext.com/advisories/cve-2025-68154 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: systeminformation 5.27.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm systeminformation: affected < 5.27.14; fixed in 5.27.14 ## Suggested inspection (read-only) - `npm ls systeminformation --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on systeminformation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wphj-fx3q-84ch (OSV record GHSA-wphj-fx3q-84ch lists affected ranges: npm systeminformation >=0 <5.27.14 (fixed)) - Verified: https://github.com/advisories/GHSA-wphj-fx3q-84ch (GitHub-reviewed advisory GHSA-wphj-fx3q-84ch lists affected ranges: npm systeminformation >=0 <5.27.14) Commands are suggestions: review each one before running it.
Loading voting…