Skip to content

← Actionable
Medium, CVSS 6.3amended

mcp-server-git argument injection in git_diff and git_checkout functions allows overwriting local files

CVE-2025-68144GHSA-9xwc-hfwc-8w59

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-server-git 2025.12.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:H/SA:L · score source
EPSS
  • CVE-2025-68144: 7.21% estimated exploitation activity in the next 30 days; percentile 94.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In mcp-server-git versions prior to 2025.12.18, the gitdiff and gitcheckout functions passed user-controlled arguments directly to git CLI commands without sanitization. Flag-like values (e.g., --output=/path/to/file for gitdiff) would be interpreted as command-line options rather than git refs, enabling arbitrary file overwrites. The fix adds validation that rejects arguments starting with - and verifies the argument resolves to a valid git ref via revparse before execution. Users are advised to update to 2025.12.18 resolve this issue. Thank you to https://hackerone.com/yardenporat for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9xwc-hfwc-8w59

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9xwc-hfwc-8w59

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68144

Advisory: mcp-server-git argument injection in git_diff and git_checkout functions allows overwriting local files
IDs: CVE-2025-68144, GHSA-9xwc-hfwc-8w59
Record: https://patchnext.com/advisories/cve-2025-68144 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-server-git 2025.12.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp-server-git: affected < 2025.12.18; fixed in 2025.12.18

## Suggested inspection (read-only)
- `python -m pip show mcp-server-git`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-server-git.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9xwc-hfwc-8w59 (OSV record GHSA-9xwc-hfwc-8w59 lists affected ranges: PyPI mcp-server-git >=0 <2025.12.18 (fixed))
- Verified: https://github.com/advisories/GHSA-9xwc-hfwc-8w59 (GitHub-reviewed advisory GHSA-9xwc-hfwc-8w59 lists affected ranges: PyPI mcp-server-git >=0 <2025.12.18)

Commands are suggestions: review each one before running it.

Loading voting…