mcp-server-git's unrestricted git_init tool allows repository creation at arbitrary filesystem locations
CVE-2025-68143GHSA-5cgr-j3jf-jw3v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-server-git 2025.9.25), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mcp-server-git
- Affected
- < 2025.9.25
- Fixed in
- 2025.9.25
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5cgr-j3jf-jw3v lists affected ranges: PyPI mcp-server-git >=0 <2025.9.25 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5cgr-j3jf-jw3v lists affected ranges: PyPI mcp-server-git >=0 <2025.9.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2025-68143: 8.13% estimated exploitation activity in the next 30 days; percentile 94.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In mcp-server-git versions prior to 2025.9.25, the gitinit tool accepted arbitrary filesystem paths and created Git repositories without validating the target location. Unlike other tools which required an existing repository, gitinit could operate on any directory accessible to the server process, making those directories eligible for subsequent git operations. The tool was removed entirely, as the server is intended to operate on existing repositories only. Users are advised to upgrade to 2025.9.25 or newer to remediate this issue. Thank you to https://hackerone.com/yardenporat for disclosure, @0dd for contributing the fix.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5cgr-j3jf-jw3v
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5cgr-j3jf-jw3v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68143 Advisory: mcp-server-git's unrestricted git_init tool allows repository creation at arbitrary filesystem locations IDs: CVE-2025-68143, GHSA-5cgr-j3jf-jw3v Record: https://patchnext.com/advisories/cve-2025-68143 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mcp-server-git 2025.9.25. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mcp-server-git: affected < 2025.9.25; fixed in 2025.9.25 ## Suggested inspection (read-only) - `python -m pip show mcp-server-git`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mcp-server-git. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5cgr-j3jf-jw3v (OSV record GHSA-5cgr-j3jf-jw3v lists affected ranges: PyPI mcp-server-git >=0 <2025.9.25 (fixed)) - Verified: https://github.com/advisories/GHSA-5cgr-j3jf-jw3v (GitHub-reviewed advisory GHSA-5cgr-j3jf-jw3v lists affected ranges: PyPI mcp-server-git >=0 <2025.9.25) Commands are suggestions: review each one before running it.
Loading voting…