Skip to content

← Actionable
Medium, CVSS 6.8

Auth0-PHP SDK has Improper Audience Validation

CVE-2025-68129GHSA-j2vm-wrq3-f7gf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0/auth0-php 8.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-68129: 0.43% estimated exploitation activity in the next 30 days; percentile 36.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. Affected product and versions Projects are affected if they meet the following preconditions: - Applications using the Auth0-PHP SDK, versions between v8.0.0 and v8.17.0, or - Applications using the following SDKs that rely on the Auth0-PHP SDK versions between v8.0.0 and v8.17.0: - a. Auth0/symfony, - b. Auth0/laravel-auth0, - c. Auth0/wordpress. Resolution Upgrade Auth0/Auth0-PHP to version 8.18.0 or greater. Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j2vm-wrq3-f7gf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-68129

Advisory: Auth0-PHP SDK has Improper Audience Validation
IDs: CVE-2025-68129, GHSA-j2vm-wrq3-f7gf
Record: https://patchnext.com/advisories/cve-2025-68129 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0/auth0-php 8.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist auth0/auth0-php: affected >= 8.0.0, < 8.18.0; fixed in 8.18.0

## Suggested inspection (read-only)
- Packagist auth0/auth0-php: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0/auth0-php.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j2vm-wrq3-f7gf (GitHub-reviewed advisory GHSA-j2vm-wrq3-f7gf lists affected ranges: Packagist auth0/auth0-php >=8.0.0 <8.18.0)

Commands are suggestions: review each one before running it.

Loading voting…