Visual Studio Code Go extension has unexpected untrusted code execution
CVE-2025-68120GHSA-fjmr-7667-8v4p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/golang/vscode-go 0.52.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/golang/vscode-go
- Affected
- < 0.52.1
- Fixed in
- 0.52.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fjmr-7667-8v4p lists affected ranges: Go github.com/golang/vscode-go >=0 <0.52.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L
- EPSS
- CVE-2025-68120: 0.45% estimated exploitation activity in the next 30 days; percentile 39.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
To prevent unexpected untrusted code execution, the Visual Studio Code Go extension is now disabled in Restricted Mode.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fjmr-7667-8v4p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68120 Advisory: Visual Studio Code Go extension has unexpected untrusted code execution IDs: CVE-2025-68120, GHSA-fjmr-7667-8v4p Record: https://patchnext.com/advisories/cve-2025-68120 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/golang/vscode-go 0.52.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/golang/vscode-go: affected < 0.52.1; fixed in 0.52.1 ## Suggested inspection (read-only) - Go github.com/golang/vscode-go: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/golang/vscode-go. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fjmr-7667-8v4p (GitHub-reviewed advisory GHSA-fjmr-7667-8v4p lists affected ranges: Go github.com/golang/vscode-go >=0 <0.52.1) Commands are suggestions: review each one before running it.
Loading voting…