ALTCHA Proof-of-Work Vulnerable to Challenge Splicing and Replay
CVE-2025-68113GHSA-6gvq-jcmp-8959
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (altcha 1.0.0; altcha 1.0.0; altcha-org/altcha 1.3.1; github.com/altcha-org/altcha-lib-go 1.0.0; org.altcha:altcha 1.3.0; 1 more package under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems altcha
- Affected
- < 1.0.0
- Fixed in
- 1.0.0
PyPI altcha
- Affected
- < 1.0.0
- Fixed in
- 1.0.0
Packagist altcha-org/altcha
- Affected
- < 1.3.1
- Fixed in
- 1.3.1
Go github.com/altcha-org/altcha-lib-go
- Affected
- < 1.0.0
- Fixed in
- 1.0.0
Maven org.altcha:altcha
- Affected
- < 1.3.0
- Fixed in
- 1.3.0
npm altcha-lib
- Affected
- < 1.4.1
- Fixed in
- 1.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-1115 lists affected ranges: PyPI altcha >=0 <1.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6gvq-jcmp-8959 lists affected ranges: npm altcha-lib >=0 =0 =0 =0 =0 =0 <1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2025-68113: 0.46% estimated exploitation activity in the next 30 days; percentile 40.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A cryptographic semantic binding flaw in ALTCHA libraries allows challenge payload splicing, which may enable replay attacks. The HMAC signature does not unambiguously bind challenge parameters to the nonce, allowing an attacker to reinterpret a valid proof-of-work submission with a modified expiration value. This may allow previously solved challenges to be reused beyond their intended lifetime, depending on server-side replay handling and deployment assumptions. The vulnerability primarily impacts abuse-prevention mechanisms such as rate limiting and bot mitigation. It does not directly affect data confidentiality or integrity. Patches This issue has been addressed by enforcing explicit semantic separation between challenge parameters and the nonce during HMAC computation. Users are advised to upgrade to patched versions. Workarounds As a mitigation, implementations may append a delimiter to the end of the salt value prior to HMAC computation (for example,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6gvq-jcmp-8959
- Revision 1 · created ·
Published from osv record PYSEC-2026-1115
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-68113 Advisory: ALTCHA Proof-of-Work Vulnerable to Challenge Splicing and Replay IDs: CVE-2025-68113, GHSA-6gvq-jcmp-8959 Record: https://patchnext.com/advisories/cve-2025-68113 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: altcha 1.0.0; altcha 1.0.0; altcha-org/altcha 1.3.1; github.com/altcha-org/altcha-lib-go 1.0.0; org.altcha:altcha 1.3.0; altcha-lib 1.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems altcha: affected < 1.0.0; fixed in 1.0.0 - PyPI altcha: affected < 1.0.0; fixed in 1.0.0 - Packagist altcha-org/altcha: affected < 1.3.1; fixed in 1.3.1 - Go github.com/altcha-org/altcha-lib-go: affected < 1.0.0; fixed in 1.0.0 - Maven org.altcha:altcha: affected < 1.3.0; fixed in 1.3.0 - npm altcha-lib: affected < 1.4.1; fixed in 1.4.1 ## Suggested inspection (read-only) - RubyGems altcha: check the installed version with your package manager. - `python -m pip show altcha`: prints the installed version. Run with the environment that serves production active. - Packagist altcha-org/altcha: check the installed version with your package manager. - Go github.com/altcha-org/altcha-lib-go: check the installed version with your package manager. - Maven org.altcha:altcha: check the installed version with your package manager. - `npm ls altcha-lib --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on altcha, altcha-org/altcha, github.com/altcha-org/altcha-lib-go, org.altcha:altcha, altcha-lib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2026-1115 (OSV record PYSEC-2026-1115 lists affected ranges: PyPI altcha >=0 <1.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-6gvq-jcmp-8959 (GitHub-reviewed advisory GHSA-6gvq-jcmp-8959 lists affected ranges: npm altcha-lib >=0 =0 =0 =0 =0 =0 <1.0.0) Commands are suggestions: review each one before running it.
Loading voting…