PHP CVE-2025-67899: uriparser through 0.9.9 allows unbounded recursion and stack consumption
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (php 8.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime php
- Affected
- >= 8.5.0, < 8.5.1
- Fixed in
- 8.5.1
Sources
- php.net runtime security intelligence
php.net's PHP 8 ChangeLog lists CVE-2025-67899 as fixed in PHP 8.5.1 (released 2025-12-18).
VerifiedObserved Official php.net PHP 8 ChangeLog (vendor page). Fixed versions are listed per release branch only.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2025-67899: 0.14% estimated exploitation activity in the next 30 days; percentile 3.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
php.net's PHP 8 ChangeLog lists CVE-2025-67899 as fixed in PHP 8.5.1. Partial ranges: only these branches are listed, so other PHP versions are unknown (not confirmed unaffected) until NVD publishes product data. Fixed CVE-2025-67899 (uriparser through 0.9.9 allows unbounded recursion and stack consumption).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from vendor_advisory record php-changelog-8:CVE-2025-67899
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-67899 Advisory: PHP CVE-2025-67899: uriparser through 0.9.9 allows unbounded recursion and stack consumption IDs: CVE-2025-67899 Record: https://patchnext.com/advisories/cve-2025-67899 (revision 1, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: php 8.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime php: affected >= 8.5.0, < 8.5.1; fixed in 8.5.1 ## Suggested inspection (read-only) - runtime php: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on php. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.php.net/ChangeLog-8.php (php.net's PHP 8 ChangeLog lists CVE-2025-67899 as fixed in PHP 8.5.1 (released 2025-12-18).) Commands are suggestions: review each one before running it.
Loading voting…