Skip to content

← Actionable
Critical, CVSS 9.8amended

Apache Airflow Providers Edge3 exposes internal API allowing RCE in web server context

CVE-2025-67895GHSA-66h8-3g48-6hx8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-edge3 2.0.0; apache-airflow 2.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-67895: 1.17% estimated exploitation activity in the next 30 days; percentile 67.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Edge3 Worker RPC RCE on Airflow 2. This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if projects installed and configured it on Airflow 2. The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if projects installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do. If projects installed and configured Edge3 provider for Airflow 2, they should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (>=2.0.0) has a minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2. If projects used Edge Provider in Airflow 3, you they are not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 6 · amended ·

    Amended from osv record GHSA-66h8-3g48-6hx8

  2. Revision 5 · amended ·

    Amended from ghsa record GHSA-66h8-3g48-6hx8

  3. Revision 4 · amended ·

    Amended from ghsa record GHSA-66h8-3g48-6hx8

  4. Revision 3 · amended ·

    Amended from osv record PYSEC-2025-87

  5. Revision 2 · amended ·

    Amended from osv record GHSA-66h8-3g48-6hx8

  6. Revision 1 · created ·

    Published from ghsa record GHSA-66h8-3g48-6hx8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-67895

Advisory: Apache Airflow Providers Edge3 exposes internal API allowing RCE in web server context
IDs: CVE-2025-67895, GHSA-66h8-3g48-6hx8
Record: https://patchnext.com/advisories/cve-2025-67895 (revision 6, source checked 27 Oct 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-edge3 2.0.0; apache-airflow 2.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow-providers-edge3: affected < 2.0.0; fixed in 2.0.0
- PyPI apache-airflow: affected < 2.0.0; fixed in 2.0.0

## Suggested inspection (read-only)
- `python -m pip show apache-airflow-providers-edge3`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow-providers-edge3, apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-66h8-3g48-6hx8 (GitHub-reviewed advisory GHSA-66h8-3g48-6hx8 lists affected ranges: PyPI apache-airflow-providers-edge3 >=0 <2.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-66h8-3g48-6hx8 (OSV record GHSA-66h8-3g48-6hx8 lists affected ranges: PyPI apache-airflow-providers-edge3 >=0 <2.0.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2025-87 (OSV record PYSEC-2025-87 lists affected ranges: PyPI apache-airflow >=0 <2.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…