Skip to content

← Actionable
High, CVSS 7.5

Moodle Affected by Improper Restriction of Excessive Authentication Attempts

CVE-2025-67853GHSA-5cx4-w4fh-fr57

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 5.1.1, 5.0.4, 4.5.8, 4.4.12, 4.1.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    < 4.1.22>= 4.4.0-beta, < 4.4.12>= 4.5.0-beta, < 4.5.8>= 5.0.0-beta, < 5.0.4>= 5.1.0-beta, < 5.1.1
    Fixed in
    5.0.4, 4.4.12, 4.1.22, 5.1.1, 4.5.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-67853: 0.46% estimated exploitation activity in the next 30 days; percentile 40.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in Moodle. A remote attacker could exploit a lack of proper rate limiting in the confirmation email service. This vulnerability allows attackers to more easily enumerate or guess user credentials, facilitating brute-force attacks against user accounts.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5cx4-w4fh-fr57

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-67853

Advisory: Moodle Affected by Improper Restriction of Excessive Authentication Attempts
IDs: CVE-2025-67853, GHSA-5cx4-w4fh-fr57
Record: https://patchnext.com/advisories/cve-2025-67853 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 5.1.1, 5.0.4, 4.5.8, 4.4.12, 4.1.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected < 4.1.22; >= 4.4.0-beta, < 4.4.12; >= 4.5.0-beta, < 4.5.8; >= 5.0.0-beta, < 5.0.4; >= 5.1.0-beta, < 5.1.1; fixed in 5.0.4, 4.4.12, 4.1.22, 5.1.1, 4.5.8

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5cx4-w4fh-fr57 (GitHub-reviewed advisory GHSA-5cx4-w4fh-fr57 lists affected ranges: Packagist moodle/moodle >=0 =4.4.0-beta =4.5.0-beta =5.0.0-beta =5.1.0-beta <5.1.1)

Commands are suggestions: review each one before running it.

Loading voting…