Moodle Open Redirect vulnerability
CVE-2025-67852GHSA-qv78-6gpp-hm68
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 5.1.1, 5.0.4, 4.5.8, 4.4.12, 4.1.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- < 4.1.22>= 4.4.0-beta, < 4.4.12>= 4.5.0-beta, < 4.5.8>= 5.0.0-beta, < 5.0.4>= 5.1.0-beta, < 5.1.1
- Fixed in
- 5.0.4, 4.4.12, 4.1.22, 5.1.1, 4.5.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qv78-6gpp-hm68 lists affected ranges: Packagist moodle/moodle >=0 =4.4.0-beta =4.5.0-beta =5.0.0-beta =5.1.0-beta <5.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-67852: 0.26% estimated exploitation activity in the next 30 days; percentile 17.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in Moodle. An Open Redirect vulnerability in the OAuth login flow allows a remote attacker to redirect users to attacker-controlled pages after they have successfully authenticated. This occurs due to insufficient validation of redirect parameters, which could lead to phishing attacks or information disclosure.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qv78-6gpp-hm68
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-67852 Advisory: Moodle Open Redirect vulnerability IDs: CVE-2025-67852, GHSA-qv78-6gpp-hm68 Record: https://patchnext.com/advisories/cve-2025-67852 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 5.1.1, 5.0.4, 4.5.8, 4.4.12, 4.1.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected < 4.1.22; >= 4.4.0-beta, < 4.4.12; >= 4.5.0-beta, < 4.5.8; >= 5.0.0-beta, < 5.0.4; >= 5.1.0-beta, < 5.1.1; fixed in 5.0.4, 4.4.12, 4.1.22, 5.1.1, 4.5.8 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qv78-6gpp-hm68 (GitHub-reviewed advisory GHSA-qv78-6gpp-hm68 lists affected ranges: Packagist moodle/moodle >=0 =4.4.0-beta =4.5.0-beta =5.0.0-beta =5.1.0-beta <5.1.1) Commands are suggestions: review each one before running it.
Loading voting…