Lightning Flow Scanner Vulnerable to Code Injection via Unsafe Use of new Function() in APIVersion Rule
CVE-2025-67750GHSA-55jh-84jv-8mx8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lightning-flow-scanner 6.10.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 6.10.6
- Fixed in
- 6.10.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-55jh-84jv-8mx8 lists affected ranges: npm lightning-flow-scanner >=0 <6.10.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-55jh-84jv-8mx8 lists affected ranges: npm lightning-flow-scanner >=0 <6.10.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-67750: 0.19% estimated exploitation activity in the next 30 days; percentile 9.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The APIVersion rule uses new Function() to evaluate expression strings. A malicious crafted flow metadata file can cause arbitrary JavaScript execution during scanning. An attacker could execute arbitrary JavaScript during a scan by supplying a malicious expression within rule configuration or crafted flow metadata. This could compromise developer machines, CI runners, or editor environments. Patches The patch removes all uses of new Function() and replaces them with a safer parser. It now validates operators (, =, <, <=, ==) and performs numeric comparisons without evaluating untrusted JavaScript. version: core-v6.10.6, version vsx:: v2.4.4 version app:: v3.1.0 Work around
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-55jh-84jv-8mx8
- Revision 1 · created ·
Published from osv record GHSA-55jh-84jv-8mx8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-67750 Advisory: Lightning Flow Scanner Vulnerable to Code Injection via Unsafe Use of `new Function()` in APIVersion Rule IDs: CVE-2025-67750, GHSA-55jh-84jv-8mx8 Record: https://patchnext.com/advisories/cve-2025-67750 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lightning-flow-scanner 6.10.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm lightning-flow-scanner: affected < 6.10.6; fixed in 6.10.6 ## Suggested inspection (read-only) - `npm ls lightning-flow-scanner --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lightning-flow-scanner. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-55jh-84jv-8mx8 (OSV record GHSA-55jh-84jv-8mx8 lists affected ranges: npm lightning-flow-scanner >=0 <6.10.6 (fixed)) - Verified: https://github.com/advisories/GHSA-55jh-84jv-8mx8 (GitHub-reviewed advisory GHSA-55jh-84jv-8mx8 lists affected ranges: npm lightning-flow-scanner >=0 <6.10.6) Commands are suggestions: review each one before running it.
Loading voting…