Skip to content

← Actionable
High, CVSS 7.1amended

Fickling has Code Injection vulnerability via pty.spawn()

CVE-2025-67748GHSA-r7v6-mfhq-g3m2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fickling 0.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI fickling

    Affected
    < 0.1.6
    Fixed in
    0.1.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-67748: 0.27% estimated exploitation activity in the next 30 days; percentile 19.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Fickling Assessment Based on the test case provided in the original report below, this bypass was caused by pty missing from our block list of unsafe module imports (as previously documented in #108), rather than the unused variable heuristic. This led to unsafe pickles based on pty.spawn() being incorrectly flagged as LIKELYSAFE, and was fixed in https://github.com/trailofbits/fickling/pull/187. Original report Summary An unsafe deserialization vulnerability in Fickling allows a crafted pickle file to bypass the "unused variable" heuristic, enabling arbitrary code execution. This bypass is achieved by adding a trivial operation to the pickle file that "uses" the otherwise unused variable left on the stack after a malicious operation, tricking the detection mechanism into classifying the file as safe. Details Fickling relies on the heuristic of detecting unused variables in the VM's stack after execution. Opcodes like REDUCE, OBJ, and INST, which can be used for arbitrary code…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r7v6-mfhq-g3m2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r7v6-mfhq-g3m2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-67748

Advisory: Fickling has Code Injection vulnerability via pty.spawn()
IDs: CVE-2025-67748, GHSA-r7v6-mfhq-g3m2
Record: https://patchnext.com/advisories/cve-2025-67748 (revision 3, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fickling 0.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fickling: affected < 0.1.6; fixed in 0.1.6

## Suggested inspection (read-only)
- `python -m pip show fickling`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fickling.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r7v6-mfhq-g3m2 (OSV record GHSA-r7v6-mfhq-g3m2 lists affected ranges: PyPI fickling >=0 <0.1.6 (fixed))
- Verified: https://github.com/advisories/GHSA-r7v6-mfhq-g3m2 (GitHub-reviewed advisory GHSA-r7v6-mfhq-g3m2 lists affected ranges: PyPI fickling >=0 <0.1.6)

Commands are suggestions: review each one before running it.

Loading voting…