Composer is vulnerable to ANSI sequence injection
CVE-2025-67746GHSA-59pp-r3rg-353g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (composer/composer 2.9.3, 2.2.26), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist composer/composer
- Affected
- >= 2.0.0, < 2.2.26>= 2.3.0, < 2.9.3
- Fixed in
- 2.9.3, 2.2.26
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-59pp-r3rg-353g lists affected ranges: Packagist composer/composer >=2.0.0 =2.3.0 <2.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-67746: 0.45% estimated exploitation activity in the next 30 days; percentile 39.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but Composer still published a CVE as it has potential for abuse, and Composer wants to be on the safe side informing users that they should upgrade. Patches 2.2.26 for 2.2 LTS or 2.9.3 for mainline.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-59pp-r3rg-353g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-67746 Advisory: Composer is vulnerable to ANSI sequence injection IDs: CVE-2025-67746, GHSA-59pp-r3rg-353g Record: https://patchnext.com/advisories/cve-2025-67746 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: composer/composer 2.9.3, 2.2.26. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist composer/composer: affected >= 2.0.0, < 2.2.26; >= 2.3.0, < 2.9.3; fixed in 2.9.3, 2.2.26 ## Suggested inspection (read-only) - Packagist composer/composer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on composer/composer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-59pp-r3rg-353g (GitHub-reviewed advisory GHSA-59pp-r3rg-353g lists affected ranges: Packagist composer/composer >=2.0.0 =2.3.0 <2.9.3) Commands are suggestions: review each one before running it.
Loading voting…