Skip to content

← Actionable
Medium, CVSS 6.3amended

Local Deep Research is Vulnerable to Server-Side Request Forgery (SSRF) in Download Service

CVE-2025-67743GHSA-9c54-gxh7-ppjc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (local-deep-research 1.3.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2025-67743: 0.32% estimated exploitation activity in the next 30 days; percentile 24.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The download service (downloadservice.py) makes HTTP requests using raw requests.get() without utilizing the application's SSRF protection (saferequests.py). This can allow attackers to access internal services and attempt to reach cloud provider metadata endpoints (AWS/GCP/Azure), as well as perform internal network reconnaissance, by submitting malicious URLs through the API, depending on the deployment and surrounding controls. CWE: CWE-918 (Server-Side Request Forgery) --- Details Vulnerable Code Location File: src/localdeepresearch/researchlibrary/services/downloadservice.py The application has proper SSRF protection implemented in security/saferequests.py and security/ssrfvalidator.py, which blocks: - Loopback addresses (127.0.0.0/8) - Private IP ranges (10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16) - AWS metadata endpoint (169.254.169.254) - Link-local addresses However, downloadservice.py bypasses this protection by using raw requests.get() directly: Attack Vector 1.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9c54-gxh7-ppjc

  2. Revision 1 · created ·

    Published from osv record GHSA-9c54-gxh7-ppjc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-67743

Advisory: Local Deep Research is Vulnerable to Server-Side Request Forgery (SSRF) in Download Service
IDs: CVE-2025-67743, GHSA-9c54-gxh7-ppjc
Record: https://patchnext.com/advisories/cve-2025-67743 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: local-deep-research 1.3.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI local-deep-research: affected >= 1.3.0, < 1.3.9; fixed in 1.3.9

## Suggested inspection (read-only)
- `python -m pip show local-deep-research`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on local-deep-research.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9c54-gxh7-ppjc (OSV record GHSA-9c54-gxh7-ppjc lists affected ranges: PyPI local-deep-research >=1.3.0 <1.3.9 (fixed))
- Verified: https://github.com/advisories/GHSA-9c54-gxh7-ppjc (GitHub-reviewed advisory GHSA-9c54-gxh7-ppjc lists affected ranges: PyPI local-deep-research >=1.3.0 <1.3.9)

Commands are suggestions: review each one before running it.

Loading voting…