HKUDS LightRAG allows Path Traversal via function upload_to_input_dir
CVE-2025-6773GHSA-v9w6-9hq9-33ch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lightrag-hku 1.3.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lightrag-hku
- Affected
- < 1.3.8
- Fixed in
- 1.3.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v9w6-9hq9-33ch lists affected ranges: PyPI lightrag-hku >=0 <1.3.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v9w6-9hq9-33ch lists affected ranges: PyPI lightrag-hku >=0 <1.3.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-6773: 0.21% estimated exploitation activity in the next 30 days; percentile 11.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in HKUDS LightRAG up to 1.3.8. It has been declared as critical. Affected by this vulnerability is the function uploadtoinputdir of the file lightrag/api/routers/documentroutes.py of the component File Upload. The manipulation of the argument file.filename leads to path traversal. It is possible to launch the attack on the local host. The identifier of the patch is 60777d535b719631680bcf5d0969bdef79ca4eaf. It is recommended to apply a patch to fix this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v9w6-9hq9-33ch
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v9w6-9hq9-33ch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-6773 Advisory: HKUDS LightRAG allows Path Traversal via function upload_to_input_dir IDs: CVE-2025-6773, GHSA-v9w6-9hq9-33ch Record: https://patchnext.com/advisories/cve-2025-6773 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lightrag-hku 1.3.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lightrag-hku: affected < 1.3.8; fixed in 1.3.8 ## Suggested inspection (read-only) - `python -m pip show lightrag-hku`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lightrag-hku. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v9w6-9hq9-33ch (OSV record GHSA-v9w6-9hq9-33ch lists affected ranges: PyPI lightrag-hku >=0 <1.3.8 (fixed)) - Verified: https://github.com/advisories/GHSA-v9w6-9hq9-33ch (GitHub-reviewed advisory GHSA-v9w6-9hq9-33ch lists affected ranges: PyPI lightrag-hku >=0 <1.3.8) Commands are suggestions: review each one before running it.
Loading voting…