Skip to content

← Actionable
High, CVSS 8.2

aircompressor Snappy and LZ4 Java-based decompressor implementation can leak information from reused output buffer

CVE-2025-67721GHSA-vx9q-rhv9-3jvg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.airlift:aircompressor-v3 3.4; io.airlift:aircompressor 2.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-67721: 0.53% estimated exploitation activity in the next 30 days; percentile 44.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Incorrect handling of malformed data in Java-based decompressor implementations for Snappy and LZ4 allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. Details With certain crafted compressed inputs, elements from the output buffer can end up in the uncompressed output. This is relevant for applications that reuse the same output buffer to uncompress multiple inputs. This can be the case of a web server that allocates a fix-sized buffer for performance purposes. This is similar to GHSA-cmp6-m4wj-q63q. Impact Applications using aircompressor as described above may leak sensitive information to external unauthorized attackers. Mitigation The vulnerability is fixed in release 3.4 and 2.0.3. However, it can be mitigated by either: Avoiding reuse of the decompression buffer across calls Clearing the decompression buffer before a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vx9q-rhv9-3jvg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-67721

Advisory: aircompressor Snappy and LZ4 Java-based decompressor implementation can leak information from reused output buffer
IDs: CVE-2025-67721, GHSA-vx9q-rhv9-3jvg
Record: https://patchnext.com/advisories/cve-2025-67721 (revision 1, source checked 26 Oct 2026, 16:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.airlift:aircompressor-v3 3.4; io.airlift:aircompressor 2.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.airlift:aircompressor-v3: affected < 3.4; fixed in 3.4
- Maven io.airlift:aircompressor: affected < 2.0.3; fixed in 2.0.3

## Suggested inspection (read-only)
- Maven io.airlift:aircompressor-v3: check the installed version with your package manager.
- Maven io.airlift:aircompressor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.airlift:aircompressor-v3, io.airlift:aircompressor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vx9q-rhv9-3jvg (GitHub-reviewed advisory GHSA-vx9q-rhv9-3jvg lists affected ranges: Maven io.airlift:aircompressor-v3 >=0 =0 <2.0.3)

Commands are suggestions: review each one before running it.

Loading voting…