Shopware Storefront Reflected XSS in Storefront Login Page
CVE-2025-67648GHSA-6w82-v552-wjw2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/storefront 6.7.5.1, 6.6.10.10; shopware/shopware 6.7.5.1, 6.6.10.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/storefront
- Affected
- >= 6.4.6.0, < 6.6.10.10>= 6.7.0.0, < 6.7.5.1
- Fixed in
- 6.7.5.1, 6.6.10.10
Packagist shopware/shopware
- Affected
- >= 6.4.6.0, < 6.6.10.10>= 6.7.0.0, < 6.7.5.1
- Fixed in
- 6.7.5.1, 6.6.10.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6w82-v552-wjw2 lists affected ranges: Packagist shopware/shopware >=6.4.6.0 =6.7.0.0 =6.4.6.0 =6.7.0.0 <6.7.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N
- EPSS
- CVE-2025-67648: 0.19% estimated exploitation activity in the next 30 days; percentile 8.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact By exploiting the XSS vulnerabilities, malicious actors can perform harmful actions in the user's web browser in the session context of the affected user. Some examples of this include, but are not limited to: Obtaining user session tokens. Performing administrative actions (when an administrative user is affected). These vulnerabilities pose a high security risk. Since a sensitive cookie is not configured with the HttpOnly attribute and administrator JWTs are stored in sessionStorage, any successful XSS attack could enable the theft of session cookies and administrative tokens. Description A request parameter from the URL of the login page is directly rendered within the Twig template of the Storefront login page without further processing or input validation. This allows direct code injection into the template via the URL parameter. An attacker can create malicious links that could be used in a phishing attack. The parameter waitTime lacks proper input validation. The attack…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6w82-v552-wjw2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-67648 Advisory: Shopware Storefront Reflected XSS in Storefront Login Page IDs: CVE-2025-67648, GHSA-6w82-v552-wjw2 Record: https://patchnext.com/advisories/cve-2025-67648 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/storefront 6.7.5.1, 6.6.10.10; shopware/shopware 6.7.5.1, 6.6.10.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/storefront: affected >= 6.4.6.0, < 6.6.10.10; >= 6.7.0.0, < 6.7.5.1; fixed in 6.7.5.1, 6.6.10.10 - Packagist shopware/shopware: affected >= 6.4.6.0, < 6.6.10.10; >= 6.7.0.0, < 6.7.5.1; fixed in 6.7.5.1, 6.6.10.10 ## Suggested inspection (read-only) - Packagist shopware/storefront: check the installed version with your package manager. - Packagist shopware/shopware: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/storefront, shopware/shopware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6w82-v552-wjw2 (GitHub-reviewed advisory GHSA-6w82-v552-wjw2 lists affected ranges: Packagist shopware/shopware >=6.4.6.0 =6.7.0.0 =6.4.6.0 =6.7.0.0 <6.7.5.1) Commands are suggestions: review each one before running it.
Loading voting…