Skip to content

← Actionable
High, CVSS 8.4amended

SvelteKit is vulnerable to denial of service and possible SSRF when using prerendering

CVE-2025-67647GHSA-j62c-4x62-9r35

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sveltejs/kit 2.49.5; @sveltejs/adapter-node 5.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:H/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-67647: 0.52% estimated exploitation activity in the next 30 days; percentile 44.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Versions of SvelteKit are vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. Details Affected versions from 2.44.0 onwards are vulnerable to DoS if: - your app has at least one prerendered route (export const prerender = true) Affected versions from 2.19.0 onwards are vulnerable to DoS and SSRF if: - your app has at least one prerendered route (export const prerender = true) - AND you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation Impact The DoS causes the running server process to end. The SSRF allows access to internal services that can be reached without authentication when fetched from SvelteKit's server runtime. It is also possible to obtain an SXSS via cache poisoning, by forcing a potential CDN to cache an XSS returned by the attacker's server (the latter being able to specify the cache-control of their choice).…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j62c-4x62-9r35

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j62c-4x62-9r35

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-67647

Advisory: SvelteKit is vulnerable to denial of service and possible SSRF when using prerendering
IDs: CVE-2025-67647, GHSA-j62c-4x62-9r35
Record: https://patchnext.com/advisories/cve-2025-67647 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sveltejs/kit 2.49.5; @sveltejs/adapter-node 5.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sveltejs/kit: affected >= 2.19.0, <= 2.49.4; fixed in 2.49.5
- npm @sveltejs/adapter-node: affected >= 5.4.1, <= 5.5.0; fixed in 5.5.1

## Suggested inspection (read-only)
- `npm ls @sveltejs/kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @sveltejs/adapter-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sveltejs/kit, @sveltejs/adapter-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j62c-4x62-9r35 (OSV record GHSA-j62c-4x62-9r35 lists affected ranges: npm @sveltejs/kit >=2.19.0 =5.4.1 <5.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-j62c-4x62-9r35 (GitHub-reviewed advisory GHSA-j62c-4x62-9r35 lists affected ranges: npm @sveltejs/kit >=2.19.0 =5.4.1 <=5.5.0)

Commands are suggestions: review each one before running it.

Loading voting…