Skip to content

← Actionable
High, CVSS 7.3amended

LangGraph's SQLite is vulnerable to SQL injection via metadata filter key in SQLite checkpointer list method

CVE-2025-67644GHSA-9rwj-6rc7-p77c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph-checkpoint-sqlite 3.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2025-67644: 2.31% estimated exploitation activity in the next 30 days; percentile 83.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Context A SQL injection vulnerability exists in LangGraph's SQLite checkpoint implementation that allows attackers to manipulate SQL queries through metadata filter keys. This affects applications that accept untrusted metadata filter keys (not just filter values) in checkpoint search operations. Impact Attackers who control metadata filter keys can execute arbitrary sql queries against the database. Root Cause The metadatapredicate() function constructs SQL queries by interpolating filter keys directly into f-strings without validation: While filter values are parameterized, filter keys are not validated, allowing SQL injection. Attack Example Before Fix: Resulting SQL: Who Is Affected? LangSmith Deployment Customers: NOT Impacted LangSmith deployment customers are NOT affected by this vulnerability. LangSmith deployments do not allow configuring custom checkpointers, so the vulnerable code path cannot be reached. High Risk: Custom Server Deployments You are affected if your…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9rwj-6rc7-p77c

  2. Revision 1 · created ·

    Published from osv record GHSA-9rwj-6rc7-p77c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-67644

Advisory: LangGraph's SQLite is vulnerable to SQL injection via metadata filter key in SQLite checkpointer list method
IDs: CVE-2025-67644, GHSA-9rwj-6rc7-p77c
Record: https://patchnext.com/advisories/cve-2025-67644 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langgraph-checkpoint-sqlite 3.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langgraph-checkpoint-sqlite: affected < 3.0.1; fixed in 3.0.1

## Suggested inspection (read-only)
- `python -m pip show langgraph-checkpoint-sqlite`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langgraph-checkpoint-sqlite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9rwj-6rc7-p77c (OSV record GHSA-9rwj-6rc7-p77c lists affected ranges: PyPI langgraph-checkpoint-sqlite >=0 <3.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-9rwj-6rc7-p77c (GitHub-reviewed advisory GHSA-9rwj-6rc7-p77c lists affected ranges: PyPI langgraph-checkpoint-sqlite >=0 <3.0.1)

Commands are suggestions: review each one before running it.

Loading voting…