ZITADEL Vulnerable to Account Takeover via DOM-Based XSS in Zitadel V2 Login
CVE-2025-67495GHSA-v959-qxv6-6f8p
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.80.0-v2.20.0.20251208091519-4c879b47334e>= 1.83.4, <= 1.87.5>= 4.0.0-rc.1, < 4.7.1
- Fixed in
- 4.7.1, 1.80.0-v2.20.0.20251208091519-4c879b47334e
Go github.com/zitadel/zitadel/v2
- Affected
- < 1.80.0-v2.20.0.20251208091519-4c879b47334e
- Fixed in
- 1.80.0-v2.20.0.20251208091519-4c879b47334e
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v959-qxv6-6f8p lists affected ranges: Go github.com/zitadel/zitadel >=0 =1.83.4 =4.0.0-rc.1 =0 <1.80.0-v2.20.0.20251208091519-4c879b47334e
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2025-67495: 0.30% estimated exploitation activity in the next 30 days; percentile 22.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A potential vulnerability exists in ZITADEL's logout endpoint in login V2. This endpoint accepts serval parameters including a postlogoutredirect. When this parameter is specified, users will be redirected to the site that is provided via this parameter. ZITADEL's login UI did not ensure that this parameter contained an allowed value and even executed passed scripts. Impact Zitadel is vulnerable to a DOM-Based XSS vulnerability. More specifically, the /logout endpoint insecurely routed to value that is supplied in the postlogoutredirect GET parameter. As a result, malicious JS code could be executed on Zitadel users’ browsers, in the Zitadel V2 Login domain. An unauthenticated remote attacker can exploit this DOM-based XSS vulnerability, and thus, execute malicious JavaScript code on behalf of Zitadel users. By doing so, such an attacker could reset the password of their victims, and take over their accounts. Note that for this to work, multiple user sessions need to be…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v959-qxv6-6f8p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-67495 Advisory: ZITADEL Vulnerable to Account Takeover via DOM-Based XSS in Zitadel V2 Login IDs: CVE-2025-67495, GHSA-v959-qxv6-6f8p Record: https://patchnext.com/advisories/cve-2025-67495 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/zitadel/zitadel 4.7.1, 1.80.0-v2.20.0.20251208091519-4c879b47334e; github.com/zitadel/zitadel/v2 1.80.0-v2.20.0.20251208091519-4c879b47334e. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/zitadel/zitadel: affected < 1.80.0-v2.20.0.20251208091519-4c879b47334e; >= 1.83.4, <= 1.87.5; >= 4.0.0-rc.1, < 4.7.1; fixed in 4.7.1, 1.80.0-v2.20.0.20251208091519-4c879b47334e - Go github.com/zitadel/zitadel/v2: affected < 1.80.0-v2.20.0.20251208091519-4c879b47334e; fixed in 1.80.0-v2.20.0.20251208091519-4c879b47334e ## Suggested inspection (read-only) - Go github.com/zitadel/zitadel: check the installed version with your package manager. - Go github.com/zitadel/zitadel/v2: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/zitadel/zitadel, github.com/zitadel/zitadel/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v959-qxv6-6f8p (GitHub-reviewed advisory GHSA-v959-qxv6-6f8p lists affected ranges: Go github.com/zitadel/zitadel >=0 =1.83.4 =4.0.0-rc.1 =0 <1.80.0-v2.20.0.20251208091519-4c879b47334e) Commands are suggestions: review each one before running it.
Loading voting…